Rspec 1.2.4 Released


#1

rspec version 1.2.4 has been released!

Be sure to check History.rdoc and Updgrade.rdoc at
http://rspec.rubyforge.org/rspec/1.2.4/ before upgrading.

Behaviour Driven Development for Ruby.

Changes:

Version 1.2.4

  • bug fix
    • just one - update the manifest

Version 1.2.3

  • enhancements

    • support for specifying single examples with colon syntax. Closes
      #712.
      (Ben M.)
      • you can now say “spec some_spec.rb:12” in addition to “spec
        some_spec.rb
        –line 12”
    • run specs locally with --drb if no drb server is running. Closes
      #780.
      • still prints “No server running” to stderr
  • bug fixes

    • support expectations on DelegateClass (Clifford T. Matthews). Closes
      #48.
    • Fixed match_array blows up if elements can’t be sorted (Jeff
      Dean). Closes #779.
  • deprecations

    • BaseFormatter#add_example_group (use #example_group_started instead)
    • ExampleGroupProxy#backtrace (use #location instead)
    • ExampleProxy#backtrace (use #location instead)
    • BaseFormatter#example_pending now expects two arguments. The third
      argument is deprecated.
    • ExampleGroupProxy#filtered_description. This was only used in one
      place
      internally, and was a confusing solution to the problem. If you’ve
      got a
      custom formatter that uses it, you can just use
      ExampleGroupProxy#description and modify it directly.
    • predicate_matchers (use the new Matcher DSL instead)
    • Spec::Matchers.create (use Spec::Matchers.define instead)
  • http://rspec.info

  • http://rubyforge.org/projects/rspec

  • http://github.com/dchelimsky/rspec/wikis

  • removed_email_address@domain.invalid


#2

Just tried it out. Something missed?

-lenny

cat t.rb

describe ‘test’ do
it “should not fail” do
[‘A’].should include(‘A’)
end
end

spec -v

rspec 1.2.4

spec t.rb
F

NoMethodError in ‘test should not fail’
undefined method `helper’ for #Spec::Matchers::Matcher:0x66402c41
t.rb:3:


#3

On Thu, Apr 16, 2009 at 11:23 PM, Lenny M. removed_email_address@domain.invalid wrote:

it “should not fail” do

rspec gems and re-installing only rspec 1.2.4 but that still didn’t work.
Anyone else running into this? Maybe a JRuby issue?

There is an issue with JRuby and RSpec >= 1.2.0 that only reveals
itself under special circumstances, but reveals itself all the time
with 1.2.3/4.

Please stick with 1.2.2 for now. There will be a 1.2.5 release some
time soon that will fix this issue so you can upgrade then (or you can
build now from git).

Thanks,
David


#4

On Apr 15, 2009, at 11:23 AM, Lenny M. wrote:

end
undefined method `helper’ for #Spec::Matchers::Matcher:0x66402c41
t.rb:3:

I thought I must be crazy since no-one else seems to be complaining
about this but I do still have this problem. I previously left out an
important detail that I am using jruby 1.2.0. This was probably
present in 1.2.3 but I had previously been at 1.2.2. No problems with
MRI. I tried removing all rspec gems and re-installing only rspec
1.2.4 but that still didn’t work. Anyone else running into this? Maybe
a JRuby issue?

Full backtrace:

NoMethodError in ‘test should not fail’
undefined method helper' for #<Spec::Matchers::Matcher:0x374287a9> /Users/Shared/eds_test/share/RubyGems/1.8/gems/rspec-1.2.4/lib/spec/ matchers/include.rb:22:in__instance_exec0’
/Users/Shared/eds_test/share/RubyGems/1.8/gems/rspec-1.2.4/lib/spec/
matchers/extensions/instance_exec.rb:19:in instance_exec' /Users/Shared/eds_test/share/RubyGems/1.8/gems/rspec-1.2.4/lib/spec/ matchers/matcher.rb:23:inmatches?’
/Users/Shared/eds_test/share/RubyGems/1.8/gems/rspec-1.2.4/lib/spec/
expectations/handler.rb:11:in handle_matcher' /Users/Shared/eds_test/share/RubyGems/1.8/gems/rspec-1.2.4/lib/spec/ expectations/extensions/kernel.rb:27:inshould’
t.rb:3:
/Users/Shared/eds_test/share/RubyGems/1.8/gems/rspec-1.2.4/lib/spec/
example/example_methods.rb:41:in instance_eval' /Users/Shared/eds_test/share/RubyGems/1.8/gems/rspec-1.2.4/lib/spec/ example/example_methods.rb:41:inexecute’
/projects/eds_test/share/jruby/lib/ruby/1.8/timeout.rb:53:in timeout' /Users/Shared/eds_test/share/RubyGems/1.8/gems/rspec-1.2.4/lib/spec/ example/example_methods.rb:38:inexecute’
/Users/Shared/eds_test/share/RubyGems/1.8/gems/rspec-1.2.4/lib/spec/
example/example_group_methods.rb:203:in run_examples' /Users/Shared/eds_test/share/RubyGems/1.8/gems/rspec-1.2.4/lib/spec/ example/example_group_methods.rb:201:ineach’
/Users/Shared/eds_test/share/RubyGems/1.8/gems/rspec-1.2.4/lib/spec/
example/example_group_methods.rb:201:in run_examples' /Users/Shared/eds_test/share/RubyGems/1.8/gems/rspec-1.2.4/lib/spec/ example/example_group_methods.rb:99:inrun’
/Users/Shared/eds_test/share/RubyGems/1.8/gems/rspec-1.2.4/lib/spec/
runner/example_group_runner.rb:23:in run' /Users/Shared/eds_test/share/RubyGems/1.8/gems/rspec-1.2.4/lib/spec/ runner/example_group_runner.rb:22:ineach’
/Users/Shared/eds_test/share/RubyGems/1.8/gems/rspec-1.2.4/lib/spec/
runner/example_group_runner.rb:22:in run' /Users/Shared/eds_test/share/RubyGems/1.8/gems/rspec-1.2.4/lib/spec/ runner/options.rb:119:inrun_examples’
/Users/Shared/eds_test/share/RubyGems/1.8/gems/rspec-1.2.4/lib/spec/
runner/command_line.rb:9:in run' /Users/Shared/eds_test/share/RubyGems/1.8/gems/rspec-1.2.4/bin/spec:4: /Users/Shared/eds_test/share/RubyGems/1.8/gems/rspec-1.2.4/bin/spec: 19:inload’
/Users/Shared/eds_test/share/RubyGems/1.8/bin/spec:19: