Rspec 1.1.3 +ZenTest 3.9.1= rspec tests not found

Hi there

Have upgraded to Rspec 1.1.3 and ZenTest 3.9.1 and have --force
re-installed rspec plugin in the relevant place, but am getting the
following when I run rake spec:autotest

spec --diff unified test/test_helper.rb

and not

spec --diff unified

Have tried looking in the plugin codes and in the ZenTest gem code, but
I can’t find what I need to change to get it to look for my rspec tests
rather than look at test/test_helper.rb

Have spent the past couple of hours googling around to find an answer,
but to no avail.

Can anyone please point me in the right direction ?

Thanks in advance !

Terry

(I know about the “script/spec” edit that I have to make so that the
“spec --diff unified” command works. Have reinstalled rspec this so many
times tonight that I can’t remember if I did it in the last
incarnation!)

Hi,
I have just been having the same problem on windows using autotest
and/or
rspec_autotest
I have successfully moved to rspec and rspec on rails 1.1.3 ZenTest
3.9.2

So if you were on windows the fix in case you still may need it is here
http://rspec.lighthouseapp.com/projects/5645/tickets/80-15670-win32-autotest-colour-script-rspec-win32console-no-output

gem update win32console
add a require ‘win32console’ to the .autotest in your rails app root
and you can (re-)enable --colour in your spec/spec.opts file (the cause
of
the problem)

I was having a similar problem on mac leopard but this was using
rspec_autotest but
i just ditched it and moved to autotest (and today rspactor ).

hth

sinclair

On Fri, Feb 8, 2008 at 6:46 PM, Terry Shuttleworth
[email protected]
wrote:

spec --diff unified
Thanks in advance !
rspec-users mailing list
[email protected]
http://rubyforge.org/mailman/listinfo/rspec-users

Cheers!
sinclair

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs