Routing problem?


#1

I just posted this and am wondering why it was taken down

I’m relatively new to Rails, so the solution to this might be more
trivial than I think However, I am working on an app, and everything
was working fine until just recently. The problem is I’m not sure
when I might have screwed up, hence my not knowing where the problem
lies.

I’m running Rails 2.1.2

All routes in routes.rb were working fine, but for some reason, a few
stopped working. Here is my routes code:


ActionController::Routing::Routes.draw do |map|

See how all your routes lay out with “rake routes”

map.connect ‘’, :controller => ‘site’

map.resources :questions, :has_many => [:replies], :collection =>
{:search => :get}
map.resources :passwords
map.resources :users, :has_one => [:password], :has_many =>
[:replies]
map.resource :session
map.resources :beta_invitations

map.new_contact ‘/contact/new’, :controller => ‘contact’, :action =>
‘new’, :conditions => { :method => :get }
map.contact ‘/contact’, :controller => ‘contact’, :action =>
‘new’, :conditions => { :method => :get }
map.contact ‘/contact’, :controller => ‘contact’, :action =>
‘create’, :conditions => { :method => :post }

map.home ‘:action’, :controller => ‘site’
map.signup ‘/signup’, :controller => ‘users’, :action => ‘new’
map.signin ‘/signin’, :controller => ‘sessions’, :action =>
‘create’
map.signout ‘/signout’, :controller => ‘sessions’, :action =>
‘destroy’
map.questions ‘/questions’, :controller => ‘site’, :action =>
‘questions’
map.privacy ‘/privacy’, :controller => ‘site’, :action =>
‘privacy_policy’
map.terms ‘/terms’, :controller => ‘site’, :action =>
‘terms_of_service’
map.about ‘/about’, :controller => ‘site’, :action => ‘about’
map.graphs ‘/graphs’, :controller => ‘graphs’, :action => ‘stats’

Install the default routes as the lowest priority.

map.connect ‘:controller/:action/:id’
map.connect ‘:controller/:action/:id.:format’

Custom handle 404/500 errors

map.notfound ‘*args’, :controller => ‘site’, :action => ‘custom404’

end

Just recently, the signup, signout, privacy, and terms paths stopped
working. The controllers and models seem to be as they were before
they stopped working and the files names haven’t changed, so I’m not
sure where to fix the problem.

If more is needed to assess the problem, please let me know. Thanks!


#2

I just posted this and am wondering why it was taken down

it was not:
http://groups.google.de/group/rubyonrails-talk/browse_thread/thread/ec58225eb0def81e?hl=de


#3

My apologies.