Routing error for css?


#1

I can’t remember when, or what I was doing, but now I can’t retrieve the
CSS files for my sites layout (I don’t think ror is handing them out
properly). I’m pretty sure that I didn’t touch anything. I don’t know
much about routes yet (I checked the routes.rb file with a freshly
generated one, and it was the same). What can be gleaned from this
development log entry?

ActionController::RoutingError (Recognition failed for
“/stylesheets/scaffold.css”):
/vendor/actionpack/lib/action_controller/routing.rb:444:in
recognition_failed' /vendor/actionpack/lib/action_controller/routing.rb:434:inrecognize!’
/vendor/railties/lib/dispatcher.rb:32:in dispatch' /vendor/railties/lib/fcgi_handler.rb:144:inprocess_request’
/vendor/railties/lib/fcgi_handler.rb:64:in process!' /vendor/railties/lib/fcgi_handler.rb:55:ineach_cgi’
/usr/lib/ruby/1.8/fcgi.rb:597:in each' /usr/lib/ruby/1.8/fcgi.rb:597:ineach_cgi’
/vendor/railties/lib/fcgi_handler.rb:55:in process!' /vendor/railties/lib/fcgi_handler.rb:21:inprocess!’
/var/www/iks/public/dispatch.fcgi:26


#2

No ideas? Would it be a good idea to recreate a rails app and then copy
over the work I’ve done?


#3

On 1/18/06, Xavier L. removed_email_address@domain.invalid wrote:

No ideas? Would it be a good idea to recreate a rails app and then copy
over the work I’ve done?

If this is an older app that used the old initialization process, you
should run “rails .” in the root of the app, so that the new
environment.rb, boot.rb, etc, etc, can be set up.