Routing Error after upgrade


#1

I successfully upgraded to Rails 1.1., but now when I point my browser
to localhost:3000, I get a the following:

Routing Error

Recognition failed for �/rails_info/properties�

Whatâ??s the best fix for this?


#2

I solved this by creating a new project. Then I copied those files
that I had changed over to the new project.

On 3/28/06, Mike A. removed_email_address@domain.invalid wrote:

Posted via http://www.ruby-forum.com/.


Rails mailing list
removed_email_address@domain.invalid
http://lists.rubyonrails.org/mailman/listinfo/rails


#3

This can happen when upgrading from a pre-1.0 project, or when you’ve
got an old copy of the dispatcher.
You can re-run the (new version of the) “rails” command on your
project (“rails .” when your working directory is your RAILS_ROOT).
Allow it to overwrite any file you haven’t customized, and that should
fix it.


#4

Tried that, William; no dice. Further, I created a new project called
test. When I ran ruby script/server within that directory, I came up
with the following error:

=> Booting lighttpd (use ‘script/server webrick’ to force WEBrick)
=> config/lighttpd.conf not found, copying from
/usr/local/lib/ruby/gems/1.8/gems/rails-1.1.0/configs/lighttpd.conf
=> Rails application started on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server (see config/lighttpd.conf for options)
Undefined config variable: var.CWD
2006-03-28 20:40:23: (configfile.c.800) source: config/lighttpd.conf
line: 8 pos: 43 parser failed somehow near here: +
Exiting

Is there something I need to tweak or update with the lighttpd web
server?