Roles edit checkboxes all offset

I have installed the latest trunk versions of engines/login/user, and am
on rails 1.1.

I ran rake sync_permissions to get a few more controllers and actions
added.

When I go to edit roles user the Permissions checkboxes for the User
role are clear and the check boxes are set and show up in the last
column of an unrelated controller instead. Also clicking check all or
none sets or clears the checkboxes of another controller, it seems they
are all offset by one or two… very weird, does anyone else see this
before I dive into the code to debug it?

Thanks

Ok fixed it, for some reason the order was different in the header and
the body of the table this diff shows the simple fix, just sort the
headers the same way the body of the table is sorted

*** vendor/plugins/user_engine/app/views/role/_form.rhtml
2006-03-28 17:59:50.733427091 -0800
— …/…/svnengines/user_engine/app/views/role/_form.rhtml
2006-03-27 16:45:59.000000000 -0800


*** 15,21 ****


! <% @all_actions.keys.sort.each do |controller_name|
controller_id = controller_name.gsub("/", “_”)
#perms_id = controller_id + “_perms”
%>
— 15,21 ----


! <% @all_actions.each_key do |controller_name|
controller_id = controller_name.gsub("/", “_”)
#perms_id = controller_id + “_perms”
%>

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs