Rmagick w/o -I

When I installed rmagick (on Debian Linux using the -dev imagemagick
packages and then sudo gem install rmagick) it said that it was
successful, but it can’t find RMagick.rb unless I specify the -I (for
include path) below. Anyone know a fix for this?

Ammon

ruby -I /usr/local/lib/ruby/gems/1.8/gems/rmagick-1.13.0/./lib -I
/usr/local/lib/ruby/gems/1.8/gems/rmagick-1.13.0/./ext/RMagick
works but
ruby -rRMagick doesn’t

On 25/07/06, Ammon C. [email protected] wrote:

ruby -rRMagick doesn’t


Posted via http://www.ruby-forum.com/.

Does explicitly requiring rubygems (ruby -rubygems -rRmagick) help?

Farrel

On Jul 25, 2006, at 10:07 AM, Ammon C. wrote:

ruby -I /usr/local/lib/ruby/gems/1.8/gems/rmagick-1.13.0/./lib -I
/usr/local/lib/ruby/gems/1.8/gems/rmagick-1.13.0/./ext/RMagick
works but
ruby -rRMagick doesn’t

You must require “rubygems” (note -rrubygems -rRMagick won’t work
either):

require -rrubygems -e “require ‘RMagick’; p Magick”

– Daniel

That was the trick! Much appreciated!!!

Daniel H. wrote:

On Jul 25, 2006, at 10:07 AM, Ammon C. wrote:

ruby -I /usr/local/lib/ruby/gems/1.8/gems/rmagick-1.13.0/./lib -I
/usr/local/lib/ruby/gems/1.8/gems/rmagick-1.13.0/./ext/RMagick
works but
ruby -rRMagick doesn’t

You must require “rubygems” (note -rrubygems -rRMagick won’t work
either):

require -rrubygems -e “require ‘RMagick’; p Magick”

– Daniel

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs