RMagick : stranges errors on Windows

Hi,
I’ve tried several configuration on RMagick and i’ve got same error on
all.

Multiple tests (in rmagick/test path) failed and someone crah ruby :

on irb :
require ‘RMagick’
img = Magick::Image.new(20,20)
f = File.new(“test.0”, “w”)
img.write(f) { self.format = “JPEG” } # --> ruby crash

example take from RMagick/test/Image3.rb line 986

And a very strange error (having it trying to play with the new gem
Dragonfly, witch do a call to list all format supported by RMagick) :

require ‘RMagick’
Magick::formats

Magick::ImageMagickError: image coder signature mismatch XTRN': 4c26e48 != 66008 @ error/module.c/OpenModule/1271 from d:/Ruby/lib/ruby/gems/1.8/gems/rmagick-2.13.1/lib/ RMagick.rb:20:ininit_formats’
from d:/Ruby/lib/ruby/gems/1.8/gems/rmagick-2.13.1/lib/
RMagick.rb:20:in `formats’
from (irb):3

but if you do it a second time :

Magick::formats

=> {“PCDS”=>"*rw-", “MNG”=>"*rw+", “GRB”=>"*rw+", … as expected

Note that ImageMagick correctly installed (the command “identify -list
format” does a call on the same function i presume and it work fine).

I’ve tried several configuration (Win XP / Vista / Ruby 1.8.6
mswin32 / Ruby 1.8.7 mingw32 / full install binary gem ImageMagick
2.9.0/2.12.0-mswin32 Rubyforge / ImageMagick 6.4.8 / 6.5.3 / 6.5.8 /
6.5.9 … ) all with the same error.

Finaly tried to build native RMagick gem in simple step on Vista /
ruby 1.8.7 (2010-01-10 patchlevel 249) [i386-mingw32] with devkit
installed : (step find from GoogleGroups RubyInstaller)

set PATH=%ImageMagickPath%;%PATH%
set CPATH=%ImageMagickPath%\include;%CPATH%
set LIBRARY_PATH=%ImageMagickPath%\lib;%LIBRARY_PATH%

  • install the native gem :
    gem install rmagick --local --no-rdoc --no-ri

Compile fine with no error, but with all the latest library, got the
same error on Magick::formats …

Have you got some ideas ??

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs