RMagick installation problems

Dear all,

I am having trouble installing/using RMagick on Ubuntu Gutsy (7.10)
Linux.
I tried various ways, and finally managed to get the installation
process
to complete “successfully” for the RMagick gem 2.3.0, after installing
both ImageMagick and GraphicsMagick via the apt-get install process,
along with several of the prerequisite libraries for the various
graphics
formats.

When trying some examples, (like the cropping example on the
transformation page),
I get this error:

$ruby rone.rb
/var/lib/gems/1.8/gems/rmagick-2.3.0/lib/RMagick2.so:
/var/lib/gems/1.8/gems/rmagick-2.3.0/lib/RMagick2.so: undefined symbol:
SketchImage - /var/lib/gems/1.8/gems/rmagick-2.3.0/lib/RMagick2.so
(LoadError)
from /usr/lib/ruby/1.8/rubygems/custom_require.rb:32:in
require' from /var/lib/gems/1.8/gems/rmagick-2.3.0/lib/RMagick.rb:11 from /usr/lib/ruby/1.8/rubygems/custom_require.rb:32:ingem_original_require’
from /usr/lib/ruby/1.8/rubygems/custom_require.rb:32:in
`require’
from rone.rb:2

Now, I’ve read in the documentation that apparently, some other
library libMagickGraphicsWand.so is sought. It’s there, it’s found,
but Rmagick still won’t work …

#ldconfig -p | grep Magick

libMagick.so.10 (libc6) => /usr/local/lib/libMagick.so.10
libMagick.so.9 (libc6) => /usr/lib/libMagick.so.9
libMagick.so (libc6) => /usr/local/lib/libMagick.so
libMagick.so (libc6) => /usr/lib/libMagick.so
libMagick++.so.10 (libc6) => /usr/local/lib/libMagick++.so.10
libMagick++.so (libc6) => /usr/local/lib/libMagick++.so
libGraphicsMagickWand.so.0 (libc6) =>
/usr/lib/libGraphicsMagickWand.so.0
libGraphicsMagick.so.1 (libc6) => /usr/lib/libGraphicsMagick.so.1

What can I do ?

Thank you very much,

Axel

Axel E. wrote:

transformation page),

libMagick++.so.10 (libc6) => /usr/local/lib/libMagick++.so.10
libMagick++.so (libc6) => /usr/local/lib/libMagick++.so
libGraphicsMagickWand.so.0 (libc6) => /usr/lib/libGraphicsMagickWand.so.0
libGraphicsMagick.so.1 (libc6) => /usr/lib/libGraphicsMagick.so.1

What can I do ?

Thank you very much,

Axel

It looks like you’ve got a mismatch between RMagick and whichever of
ImageMagick and GraphicsMagick it’s trying to use.

Rather than trying to recover from this muddle, I recommend that you
uninstall RMagick, ImageMagick, and GraphicsMagick altogether. You don’t
need to uninstall the delegates.

Then decide which of ImageMagick and GraphicsMagick you want to use.
(You only need one of them, and installing both doesn’t help anything.)
If you choose ImageMagick, decide which version you want to use.

If you want to use GraphicsMagick or a version of ImageMagick older than
6.3.0, then you’ll have to install RMagick 1.15.13. If you want to use
ImageMagick 6.3.0 or later, then you can install RMagick 2.3.0. When it
comes time to install the RMagick gem, you can use the --version option
to specify which version of RMagick to install. For example,

gem install rmagick --version 1.15.13
or
gem install rmagick --version 2.3.0

After you decide between ImageMagick and GraphicsMagick, go to the
RMagick installation FAQ,s find the HOWTO for Linux installations and
follow the instructions. Those instructions are for general Linux
installations, nothing Ubuntu-specific, but I’m sure that if you Google
for “rmagick install ubuntu” you’ll find plenty of people who have
blogged Ubuntu-specific instructions.

If you have questions post a note on the RMagick Help forum on
RubyForge.

When I set my vps up with Ruby, Rails, and Mysql I followed this article
which also has a section on how to install ImageMagic. Worked great for
me.

http://articles.slicehost.com/2007/11/23/ubuntu-gutsy-mysql-and-ror

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs