RMagick Installation error

I have installed Imagemagick and graphics magick . when i tried to
install rmagick gem im getting error as

sudo gem install rmagick-2.10.0.gem

/usr/local/ruby-enterprise/bin/ruby extconf.rb
checking for Ruby version >= 1.8.5… yes
checking for gcc… yes
checking for Magick-config… no
Can’t install RMagick 2.10.0. Can’t find Magick-config in /usr/bin:/
bin

*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
–with-opt-dir
–without-opt-dir
–with-opt-include
–without-opt-include=${opt-dir}/include
–with-opt-lib
–without-opt-lib=${opt-dir}/lib
–with-make-prog
–without-make-prog
–srcdir=.
–curdir
–ruby=/usr/local/ruby-enterprise/bin/ruby

yum install ImageMagick-devel is also done… Still im getting the same
error in installating the gem.

Hi
Try this

yum install ImageMagick-devel
gem install rmagick

Thanks and regards,
Shyam Mohan
Ruby on rails developer
Mobile : +91-86884-68400
Web : shyam.heroku.com

On Jan 18, 10:02am, Sasi [email protected] wrote:

bin

Make sure Magick-config is on the path.

Fred

Thanks Shyam… It worked nw…

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs