RMagick install problems, advice needed


#1

Hi guys, im trying to install rmagick on windows but i have some
problems with the post install, im using win2000, ruby 1.8.4 and rails
1.1, all working well.

Then i downloaded RMagick-1.9.2-IM-6.2.4-6-win32.zip from
http://rubyforge.org/projects/rmagick/ extracted and do the gem install
RMagick-win32-1.9.2-mswin32.gem , the gem was installed sucesfully but
when i do the postinstall.rb i get the following errors:

http://img517.imageshack.us/my.php?image=rmagickerror7ed.gif

I searched around but i cant find a fix to this problem, any help will
be very apreciated :slight_smile:


#2

I have had same frustration. I had to move my development to Linux for
this same reason. If you don’t have access to Linux development machine
then Microsoft Virtual Server 2003 would be good to get on your windows
box. Again I am assuming that Linux is your deploy envionment.

So to sum it up… rmagick doesn’t work with Ruby 1.8.4 on windows.

ajay

Ana B. wrote:

Hi guys, im trying to install rmagick on windows but i have some
problems with the post install, im using win2000, ruby 1.8.4 and rails
1.1, all workOing well.

Then i downloaded RMagick-1.9.2-IM-6.2.4-6-win32.zip from
http://rubyforge.org/projects/rmagick/ extracted and do the gem install
RMagick-win32-1.9.2-mswin32.gem , the gem was installed sucesfully but
when i do the postinstall.rb i get the following errors:

http://img517.imageshack.us/my.php?image=rmagickerror7ed.gif

I searched around but i cant find a fix to this problem, any help will
be very apreciated :slight_smile:


#3

Don’t know about these errors, but what I can tell you is that ruby
1.8.4does not work with RMagick. You need to downgrade to
1.8.2.


#4

When I was intalling on OSX on my laptop I read somewhere that the
rmagick gem is broken (at least on OSX) and so it was recommended that
I build it from darwinports. On my desktop which is Debian Sarge I
installed librmagick-ruby1.8.

Can you not build it from sources on windows? You may have to install
cygwin.

-bakki


#5

I downgraded by just downloading the 1.8.2 and then replacing the ruby
directory and some other minor stuff. i upgraded to rails 1.1 and i
have
had no issues on my windows box.

saureen.


#6

ok, right now i cant have acces to a linux box, so what will be a good
way to downgrade ruby on windows, i have to deinstall rails and
reinstall ruby then rails?

As i know rails1.1 doesnt work with ruby 1.8.2, hope im wrong :expressionless:


#7

Bakki K. wrote:

When I was intalling on OSX on my laptop I read somewhere that the
rmagick gem is broken (at least on OSX) and so it was recommended that
I build it from darwinports. On my desktop which is Debian Sarge I
installed librmagick-ruby1.8.

Can you not build it from sources on windows? You may have to install
cygwin.

-bakki

The rmagick gem is not broken on OS X. I tested the gem on Tiger
10.4.6 and I have not had any reports of problems with the gem. If there
is anybody who is having problems installing or using RMagick on OS X I
wish they’d drop me a line at rmagick AT rubyforge DOT org so I can try
to help.

That’s not to say that you shouldn’t use the rmagick from darwinports if
that’s what you want to do. I’m a big fan of darwinports myself.

Sadly, I have heard from people who have tried to install RMagick from
source on Cygwin but were not able to. We have not been able to figure
out why. If there is anybody who has successfully installed RMagick on
Cygwin (recently) please drop me a line and tell me what you did and
what obstacles you encountered.


#8

Thanks for the ‘heads up’. I also read, perhaps it was in either the
‘Pick Axe’ book or the ‘AWDWR’ book that RoR needed to be reinstalled in
OSX.

Since, I am going to purchase an Apple box shortly and I am using RoR
currently on an XP laptop, it would be helpful to know if RoR comes with
the Apple boxes and, if so, is it operational right out of the box…

Cheers,
Pat


#9

Ana B. wrote:

Hi guys, im trying to install rmagick on windows but i have some
problems with the post install, im using win2000, ruby 1.8.4 and rails
1.1, all working well.

Then i downloaded RMagick-1.9.2-IM-6.2.4-6-win32.zip from
http://rubyforge.org/projects/rmagick/ extracted and do the gem install
RMagick-win32-1.9.2-mswin32.gem , the gem was installed sucesfully but
when i do the postinstall.rb i get the following errors:

http://img517.imageshack.us/my.php?image=rmagickerror7ed.gif

I searched around but i cant find a fix to this problem, any help will
be very apreciated :slight_smile:

Post your question to the RMagick “help” forum on RubyForge and we’ll
try to get you some help. Normally the rmagick-win32 install is quick
and painless.


#10

Pat L. wrote:

Thanks for the ‘heads up’. I also read, perhaps it was in either the
‘Pick Axe’ book or the ‘AWDWR’ book that RoR needed to be reinstalled in
OSX.

Since, I am going to purchase an Apple box shortly and I am using RoR
currently on an XP laptop, it would be helpful to know if RoR comes with
the Apple boxes and, if so, is it operational right out of the box…

You probably read that Ruby needed reinstalling on Mac OSX. Ruby comes
preinstalled, but Apple’s installation of Ruby is slightly broken. There
is a patch for it, but most people install a clean copy in a different
location, and adjust their paths to give the new Ruby precedence over
the old one.

OSX doesn’t have Rails.

If you want the quickest route to a Rails development setup on OSX, use
Locomotive:

http://locomotive.raaum.org/

For detailed instructions on installing Ruby and Rails etc. see:

http://hivelogic.com/articles/2005/12/01/ruby_rails_lighttpd_mysql_tiger

regards

Justin


#11

Pat L. wrote:

Thanks for the ‘heads up’. I also read, perhaps it was in either the
‘Pick Axe’ book or the ‘AWDWR’ book that RoR needed to be reinstalled in
OSX.

Since, I am going to purchase an Apple box shortly and I am using RoR
currently on an XP laptop, it would be helpful to know if RoR comes with
the Apple boxes and, if so, is it operational right out of the box…

Cheers,
Pat

Just found this quick guide to installing RMagick on OS X:
http://www.oreillynet.com/ruby/blog/2006/05/interview_with_luis_lavena_2.html.
Uses Darwinports.


#12

Tim H. wrote:

Just found this quick guide to installing RMagick on OS X:
http://www.oreillynet.com/ruby/blog/2006/05/interview_with_luis_lavena_2.html.
Uses Darwinports.

Blush. Wrong paste buffer. Here’s the real URL:
http://disinnovate.blogspot.com/2006/05/installing-rmagick-on-os-x-104-tiger.html


#13

Good advice – I’ll take it – I hope I can return the favor someday.
Cheers,
Pat