Rmagick for Ruby 1.8.6 won't work for Ruby 1.8.7?

if i install

2.12.0 binary gem for Ruby 1.8.6 2009-10-04 16:05
RMagick-2.12.0-ImageMagick-6.5.6-8-Q8.zip

which is from http://rubyforge.org/frs/?group_id=12&release_id=43232

then when i use ruby 1.8.7 to

require ‘rubygems’
require ‘rmagick’

it will say:

c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_re quire': no such file to load -- rmagick (LoadError) from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inre
quire’
from try.rb:3

Does that mean I have to install Ruby 1.8.6 to cover up 1.8.7 in order
to use rmagick?

oh well, i set up a new XP SP3 virtual machine,

installed

Ruby 1.8.6 patch 398

and installed

2.12.0 binary gem for Ruby 1.8.6 2009-10-04 16:05

the same thing happened:

irb(main):001:0> require ‘rubygems’
=> true

irb(main):002:0> require ‘rmagick’
LoadError: no such file to load – rmagick
from
c:/Ruby186/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from c:/Ruby186/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from (irb):2

Then, I even installed Ruby 1.8.6-p26 legacy installer

and similar things happened. oh well… rmagick seems to be fairly
broken or some change need to make it work?

On Fri, Jul 23, 2010 at 4:24 PM, winter heat [email protected]
wrote:

irb(main):002:0> require ‘rmagick’
LoadError: no such file to load – rmagick

According to the docs, you must require ‘RMagick’… note the capital
R and M. I don’t know if that makes a difference on windows, but it’s
something to try.

Ben

ok, i don’t know whether it is required to run the .exe in the rmagick
distribution, but there needs to be one step:

cd to the path of the unzipped rmagick files
gem install rmagick --local

and then

require ‘rmagick’

will works

Luis L. wrote:

On Jul 23, 7:18�pm, winter heat [email protected] wrote:

� require ‘rmagick’

Does that mean I have to install Ruby 1.8.6 to cover up 1.8.7 in order
to use rmagick?

No, the require is case-sensitive, needs to be:

require ‘RMagick’

strange, i am using ‘rmagick’ and it works too.

On Jul 23, 7:18 pm, winter heat [email protected] wrote:

require ‘rmagick’

Does that mean I have to install Ruby 1.8.6 to cover up 1.8.7 in order
to use rmagick?

No, the require is case-sensitive, needs to be:

require ‘RMagick’

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs