RMagick 1.15.0

I’ve just uploaded RMagick 1.15.0 to RubyForge. There have been many
changes
since the previous release. Here are the highlights:

o Added the fx method to the ImageList class. This is an interface to
the -fx
option to ImageMagick’s convert and mogrify commands. See
http://redux.imagemagick.org/script/fx.php for more information about
fx.

o Added the wet_floor method to the Image class. This method creates a
“wet floor” (http://en.wikipedia.org/wiki/Wet_floor) reflection of an
image.

o Added the polaroid method to the Image class. This special effect
method
makes your image look like an old Polaroid photograph. This built in
method
was inspired by the RMagick tutorial “The Polaroid Effect”
(http://rmagick.rubyforge.org/Polaroid/polaroid.html)

o Fixed a half-dozen bugs. Thanks to all the folks who reported them!
Their
names are recorded in the Change Log.

And that’s not all. See the Change Log for details.

RMagick is available as always from RubyForge:
http://rubyforge.org/projects/rmagick/. The RMagick home page is
http://rmagick.rubyforge.org. The RMagick installation FAQ is at
http://rmagick.rubyforge.org/install-faq.html.

(This release is not yet available for MS Windows. Watch here for an
announcement.)

RMagick is an interface to the ImageMagick (www.imagemagick.org) and
GraphicsMagick (www.graphicsmagick.org) image processing libraries.
RMagick supports more than 90 image formats, including GIF, JPEG, and
PNG. RMagick comes with comprehensive HTML documentation.

Timothy H. wrote:

I’ve just uploaded RMagick 1.15.0 to RubyForge. There have been many
changes
since the previous release. Here are the highlights:

Hi, I’ve just upgraded my rails from 1.1.6 to 1.2.1 and rails now
complains about my RMagick 1.13.0 gem. I’d like to upgrade my RMagick
to 1.15.0 but I’m afraid that it’ll introduce dependencies on other
packages. I’m currently running ubuntu Dapper Drake. Does anyone know
if 1.15.0 requires the latest ImageMagick software? Thanks.

donut donut wrote:

to 1.15.0 but I’m afraid that it’ll introduce dependencies on other
packages. I’m currently running ubuntu Dapper Drake. Does anyone know
if 1.15.0 requires the latest ImageMagick software? Thanks.

RMagick 1.15.0 officially works with ImageMagick 6.0.0 or later,
although I recommend 6.2.0 or later. ImageMagick changed considerably at
its 6.2.0 release.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs