rjb/iText issue after upgrade

Hello RoR and iText users:

I have been using iText successfully with

Rails 2.3.2
Ruby 1.8.6
rjb 1.1.7

I just upgraded to

Rails 2.3.5
Ruby 1.8.7
rjb 1.3.4-x86-mswin32-60

Now, whenever I try a pdfreader.new(pdfFileName)

I get IOException: PDF header signature not found.

The file header is fine (first line starts with %PDF … as it should).
It’s not the file but a problem in reading files at all I believe.

The file exists, but I noticed that if I send a non-existent file name
to pdfreader.new I get the same error. So, I don’t know if it can’t
find the file (I’ve tried both relative and absolute path names) or if
there is something else going wrong.

I upgraded by creating an entirely new Ruby/Rails directory so it’s
possibly I left something out. I’ve tried older versions of the iText
jar but I haven’t tried back revving rjb.

If I install an older rjb, how do I get require to load that specific
version (without hardcoded path)?

Any ideas?

TIA,
Dan

Hi,

I believe that you may download old rjb’s gem from
http://rubyforge.org/frs/?group_id=2010
into your local directory.
And cd in the directy then type ‘gem install rjb -l’. (you may uninstall
rjb gem before doing that)
Gem takes from the local gem and installs it.

Regards


arton [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs