Ripper status, English docs?

What’s the status of ripper? I thought it was supposed to be in the
standard
Ruby dist now, but that doesn’t seem to be the case.

Are there any English available for Ripper?

Phil

Phil T. wrote:

Are there any English available for Ripper?

Phil

If you do a checkout from CVS it is included, and it has documentation.

– Daniel

In article
[email protected],
Daniel H. [email protected] wrote:

Phil T. wrote:

Are there any English available for Ripper?

Phil

If you do a checkout from CVS it is included, and it has documentation.

You mean checkout of Ruby 1.9? Did that, but I don’t see any docs in
the
ext/ripper directory.

Phil

Hi,

At Thu, 12 Jan 2006 15:13:03 +0900,
Phil T. wrote in [ruby-talk:175455]:

You mean checkout of Ruby 1.9? Did that, but I don’t see any docs in the
ext/ripper directory.

Documented in parse.y and ext/ripper/lib/.rb. You need to
append a line `ext/ripper/lib/
.rb’ to ext/.document file to
enable the rdoc all.

In article [email protected],
nobuyoshi nakada [email protected] wrote:

Is the latest version of ripper available for ruby 1.8? It seems that
the
version that ships with 1.9 is different (has a different API) than the
one
that is available from the ripper CVS repository.

Phil

Hi,

At Fri, 13 Jan 2006 09:28:04 +0900,
Phil T. wrote in [ruby-talk:175614]:

that is available from the ripper CVS repository.
I think it no longer supports 1.8. The latter should be quite
old.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs