Richiesta di aiuto (principiante) - installare RMagick

Salve a tutti
sto tentando di installare rmagick tramite gem, seguendo le istruzioni
trovate in
“Ruby per applicazioni web” di Marco Cerasa, ma non riesco a farlo.
Quello che ho fatto é:

1 - ho verificato che ImageMagick è installato e funziona

2 - sudo gem install -r rmagick
ottenendo, dopo qualche decina di secondi e una serie di messaggi:
Successfully installed rmagick-1.14.1

3 - gem list --local
ottenendo, tra l’altro

rmagick (1.14.1)
RMagick is an interface between the Ruby programming language and
the ImageMagick and GraphicsMagick image processing libraries.

4 - lanciando ‘irb’ e poi dando:

require ‘RMagick’

quello che ottengo è:

LoadError: no such file to load – RMagick
from (irb):1:in `require’
from (irb):1

Lo stesso risultato lo ottengo scrivendo
require ‘RMagick’ su un file .rb e poi lanciandolo con ruby.

Grazie a chi vorrà darmi un suggerimento.

se sei su windows, nel sito di rmagick c’è un installer che mette tutto
quello che ti serve senza problemi e contiene la gem e l’imagemagick
compatibili l’uno con l’altro.

On 1/6/07, Marco L. [email protected] wrote:

Successfully installed rmagick-1.14.1
require ‘RMagick’


Ml mailing list
[email protected]
http://lists.ruby-it.org/mailman/listinfo/ml


Chiaroscuro

: : i’m a miner : : | therubymine.com

Il giorno sab, 06/01/2007 alle 18.02 +0100, chiaro scuro ha scritto:

se sei su windows, nel sito di rmagick c’è un installer che mette tutto
quello che ti serve senza problemi e contiene la gem e l’imagemagick
compatibili l’uno con l’altro.

No, linux
grazie per l’attenzione

quasi dimenticavo : http://www.ruby-forum.com/topic/110620

hai provato con
require ‘rubygems’
require ‘RMagick’

Per i pacchetti installati tramite gem devi fare includere anche
‘rubygems’.

L’ho scoperto solo ieri in un’altra discussione sempre su RMagick. A me
comunque non funziona.

per Marco L.
ho risolto (con debian etch). Trovi tutto al post:
http://www.ruby-forum.com/topic/110620#256586

require ‘RMagick’ su un file .rb e poi lanciandolo con ruby.
Prova dando prima un:

export RUBYOPT=rubygems


Massimiliano M.
code: http://dev.hyperstruct.net
blog: http://blog.hyperstruct.net

Prova dando prima un:

export RUBYOPT=rubygems

Adesso funziona, davvero grazie!
Marco

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs