RGhost encoding problem

Hi everyone,

I have been using RGhost to generate pdfs, but unfortunately I am having
problems with how characters are displayed. I have followed the manual
and everything I have tried does not solve my problem. I am using Rails
3 with MySQL and I the character encoding is utf8. My operating system
is Ubuntu also with character set utf8 by default. The UTF-8 font
encoding does not work in RGhost. I have already changed the driver to
mysql2, and also tried to add :font_encoding => ‘UTF-8’ when creating
the Document instance, but I get the following error:

--------------------- beginning output message

RGhost::Error Error: /undefinedfilename in (.enc)
Operand stack:

Execution stack:
%interp_exit .runexec2 --nostringval-- --nostringval–
–nostringval-- 2 %stopped_push --nostringval–
–nostringval-- --nostringval-- false 1 %stopped_push 1878
1 3 %oparray_pop 1877 1 3 %oparray_pop 1861 1 3
%oparray_pop 1755 1 3 %oparray_pop --nostringval–
%errorexec_pop .runexec2 --nostringval-- --nostringval–
–nostringval-- 2 %stopped_push --nostringval–
Dictionary stack:
–dict:1155/1684(ro)(G)-- --dict:0/20(G)-- --dict:73/200(L)–
Current allocation mode is local
Last OS error: 2
Current file position is 66
-------------------------- end output message

It is the undefinedfilename that I am surprised with. I have looked into
/usr/lib/ruby/gems/1.8/gems/rghost-0.8.7.5/lib/rghost/ps and the file
UTF-8.enc is there.
Has anyone come across this problem before? Searching Google does not
bring any results.

Thanks in advance.

Best Regards,

Fidel.

On 12/03/11 08:33, Fidel V. wrote:

error:
1 3 %oparray_pop 1877 1 3 %oparray_pop 1861 1 3

Fidel.

Never mind! After deliberate research, I found out that there was an
illegal character in the database.

Thanks!

Fidel.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs