Reverse Proxy - Issue in 0.8.36/.37

I can’t really post my config with all information but I can post the
specific configuration for the site’s that have issues.

nginx 0.7.x does not show this problem.

If you configure a SSL reverse proxy:
server {
ssl on;
ssl_certificate /usr/local/nginx/cert/apache-cert;
ssl_certificate_key /usr/local/nginx/cert/apache-key;
ssl_session_timeout 5m;
keepalive_timeout 15;
location / {
#limit_req zone=one burst=10;
proxy_read_timeout 300;
proxy_connect_timeout 300;
proxy_redirect off;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For
proxy_set_header X-Forwarded-Proto https;

Then it always gives ‘Bad Gateway’. This issue was never present with

Setting proxy_pass to : https:// or http:// gives the same result.

Enabling or disabling buffering offers the same result.

Any ideas if this is a new bug? I have thus far, tested .36/.37 - I’m
building .38 now to see if it’s still an issue.

Any help would be greatly appreciated.

Posted at Nginx Forum:

Realized I couldn’t edit my post.

No issues are seen with reverse proxies (that we can tell) when using
standard ports. It appears to be only on non-standard ports. Firewall
had been disabled for testing as well.

tcpdump shows the connections going out and a response coming back but
it immediately drops to a ‘Bad Gateway’. Downgraded to 0.7.xx (newest)
and the issue was immediately resolved. (Exact same config file, simply
a restart of the service and it started working again with 0.7)

This issue occurred on two different systems, two different datacenters.

FreeBSD 8.0 x64 / with kqueue

Posted at Nginx Forum:


Actually it appears when I test with 0.8.38:
If I set:
gzip on;
and changed:
to http:// and restarted… The issue fixed itself.

Hmmm… Anyway, just a mention. Maybe it was a config issue?

Posted at Nginx Forum: