Retardo en la carga de paginas


#1

Buenos dias lista, estoy teniendo un problema en una aplicación en
producción, que de repente, y sin cambiar nada de la configuración va
muy lento, pero lo más curioso, es que si pulsas en cualquier link una
vez tarda como un minuto en responder, en cambio si vuelves a pulsarlo
una segunda vez carga al momento;
La verdad es que este problema ya me surgió en otra aplicación, y se fue
igual que vino.
Agradecería cualquier información que pudiese dar algo de luz al asunto.
Gracias de antemano.


#2

2008/11/28 fernando martinez gil removed_email_address@domain.invalid:

Buenos dias lista, estoy teniendo un problema en una aplicación en
producción, que de repente, y sin cambiar nada de la configuración va
muy lento, pero lo más curioso, es que si pulsas en cualquier link una
vez tarda como un minuto en responder, en cambio si vuelves a pulsarlo
una segunda vez carga al momento;
La verdad es que este problema ya me surgió en otra aplicación, y se fue
igual que vino.
Agradecería cualquier información que pudiese dar algo de luz al asunto.
Gracias de antemano.

Reinicia el ordenador.


#3

¿Cómo lo tienes montado? (apache+mongrel, nginx+mongrel,
apache+mod_rails,nginx+thin,…)
¿Qué sistema operativo?
¿Están las máquinas en el mismo país?


#4

2008/11/28 fernando martinez gil removed_email_address@domain.invalid

Fernando, un poco de seriedad y sensatez son necesarias para hacer
preguntas
en la lista, y la seriedad y la sensatez sugieren que igual que no
llamarías
a un servicio técnico de televisores para decir “no me enciende el
televisor, agradecería cualquier información que me pudiese dar algo de
luz
sobre el asunto”, porque te colgarían (el teléfono y, dependiendo del
humor
del técnico, a ti también) no puedes describir un problema de esta
manera y
hacer perder el tiempo a la gente leyendo tu mail y empezando a pedirte
la
información necesaria. La gente está ocupada, trabajando en muchos
casos, y
no se puede abusar de su tiempo y de su confianza por nuestra vagancia.

Voy a recomendar este link, que hace tiempo que no lo hacía

(en) http://www.catb.org/~esr/faqs/smart-questions.html
(es) http://www.sindominio.net/ayuda/preguntas-inteligentes.html


#5

Nginx no lo conozco así que solo será una ayuda genérica.

Lo único que se me ocurre es revisar los logs de nginx y los
mongrels(por si te sale algún error), comprobar que están todos los
mongrels levantados (ve probando 1 por 1, quizá tienes uno atontado) y
lo que ya te han recomendado antes(reiniciar).

PS: Dale a responder a todos que si no el mail me llega a mi solamente.


#6

En el log de producción te dirá para esa request el tiempo de
respuesta de rendering, de base de datos y el total.

Péganos esa línea del log y danos más info:

¿cuántas queries a base de datos se hacen en esa petición?
¿hay caché?

2008/11/28 Rafael G. removed_email_address@domain.invalid: