Require_gem question

Does require_gem also load all of the listed dependencies in the gem
spec or are those dependencies loaded by manually through require
statements?

so example:
require_gem ‘rails’

the rails gem has:
actionwebservice
actionmailer
actionpack
activerecord
activesupport
rake
as listed dependencies.

so does require_gem ‘rails’ also perform require_gem ‘actionamailer’,
etc… ? or is there a specific ‘require’ statement somewhere in ‘rails’
?

On Jul 26, 2006, at 6:09 AM, Andrew G. wrote:

actionpack
activerecord
activesupport
rake

require_gem is only useful for picking a particular version of a
gem. If you don’t manually specify the version of the dependent gems
(in dependency order) you’ll get whatever their gemspecs need.


Eric H. - [email protected] - http://blog.segment7.net
This implementation is HODEL-HASH-9600 compliant

http://trackmap.robotcoop.com

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs