Report configure - Packages skipped

Hello everyone,
I ran into a problem during installation of GNU Radio and I hope someone
can help me.
I have a Ubuntu 9.04, GNU Radio 3.2.2 and a USRP2.
I want to emphasize that I still has the best guide on the wiki,
particularly that relating to dependencies. To this I can not explain
why some skip.
During the execution of the command ./configure I get the following
reports:


The following components were skipped either because you asked not
to build them or they didn’t pass configuration checks:
usrp2-firmware
These components will not be built.

The following GNU Radio components have been successfully configured:
config
gruel
omnithread
gnuradio-core
pmt
mblock
usrp2
gr-usrp2
gr-audio-alsa
gr-audio-oss
gr-cvsd-vocoder
gr-gsm-fr-vocoder
gr-pager
gr-radio-astronomy
gr-trellis
gr-video-sdl
gr-wxgui
gr-qtgui
gnuradio-examples
grc
docs
You my now run the make command to build these components.

The following components were skipped either because you asked not
to build them or they didn’t pass configuration checks:
gcell
usrp
gr-usrp
gr-gcell
gr-audio-jack
gr-audio-osx
gr-audio-portaudio
gr-audio-windows
gr-gpio
gr-radar-mono
gr-sounder
gr-utils
These components will not be built.


In this respect I do not understand why follow packages are skipped:
"usrp2-firmware, “usrp” and “gr-utils.” Moreover, with regard to others
is normal that I should be skipped?
I hope that I answer so many, so thanks in advance.

To be precise I have installed:
SWIG 1.3.36, G++ 4.3.3, AUTOMAKE1.9 1.9.6, LIBTOOL 2.2.6, PYTHON-DEV
2.6.2, LIBCPPUNIT-DEV 1.12.1, SDCC 2.8.0, LIBASOUND2-DEV 1.0.18,
LIBSDL1.2-DEV 1.2.13, PYTHON-WGXTK2.8 2.8.9,
SUBERVISION 1.5.4, GUILE-1.8-DEV 1.8.5, LIBQT4-DEV 4.5.0, CCACHE 2.4.16,
PYTHON-OPENGL 3.0.0, LIBGSL0-DEV 1.12.1, PYTHON-CHEETAH 2.0.1,
PYTHON-LXML 2.1.5, LIBQWT5-QT4-DEV 5.1.1,
LIBQWTPLOT3D-QT4-DEV 0.2.7, QT4-DEV-TOOLS 4.5.0, LIBFFTW3-DEV 3.1.2,
DOXYGEN 1.5.8, PYTHON-NUMPY-EXT 1.2.1

On Thu, Jul 29, 2010 at 9:46 AM, Federico Battaglia
removed_email_addre[email protected] wrote:

The following components were skipped either because you asked not
mblock
gr-wxgui
gr-usrp


SUBERVISION 1.5.4, GUILE-1.8-DEV 1.8.5, LIBQT4-DEV 4.5.0, CCACHE 2.4.16,
PYTHON-OPENGL 3.0.0, LIBGSL0-DEV 1.12.1, PYTHON-CHEETAH 2.0.1, PYTHON-LXML
2.1.5, LIBQWT5-QT4-DEV 5.1.1,
LIBQWTPLOT3D-QT4-DEV 0.2.7, QT4-DEV-TOOLS 4.5.0, LIBFFTW3-DEV 3.1.2, DOXYGEN
1.5.8, PYTHON-NUMPY-EXT 1.2.1

Federico Battaglia

You don’t really need to post twice.

You can grep through the output of configure for “skipping” or
something similar and see what failed. It’s usually pretty
descriptive what it can’t find.

Brian

In particular, make sure you have the small device compiler installed
(SDCC). Not sure about gr-utils.
~Jeff
On 7/29/2010 9:46 AM, Federico Battaglia wrote:

Hello everyone,
I ran into a problem during installation of GNU Radio and I hope someone
can help me.

~Jeffrey L., K1VZX

On Thu, Jul 29, 2010 at 02:41:31PM -0400, Jeffrey L. wrote:

In particular, make sure you have the small device compiler
installed (SDCC). Not sure about gr-utils.

I think that simply depends on gr-usrp due to the usrp_*.py scripts. It
should work once usrp is up and running, it doesn’t have much stuff of
it’s own.

MB


Karlsruhe Institute of Technology (KIT)
Communications Engineering Lab (CEL)

Dipl.-Ing. Martin B.
Research Associate

Kaiserstraße 12
Building 05.01
76131 Karlsruhe

Phone: +49 721 608-3790
Fax: +49 721 608-6071
www.cel.kit.edu

KIT – University of the State of Baden-Württemberg and
National Laboratory of the Helmholtz Association

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs