Render failing in 5.2.3

#1

I’m receiving the following error after trying out Rails 5.2.3:

Missing partial homes/_header, application/_header with {:locale=>[:en], :formats=>[:html], :variants=>[], :handlers=>[:raw, :erb, :html, :builder, :ruby, :coffee, :jbuilder]}. 

In my views folder I have the following structure:

~ Views
~~ Application
~~~ _header.html.erb

And my simple render in layouts/application has:

<%= render 'header' %>

I keep all application specific partials in the application folder. Also, I have tried a direct path to the file as well. Same result.

I’m coming from Rails 4.x and testing out Rails 5.2.3.

#2

To make sure I’m also putting out how the folder path looks in my app, it looks like this to the header file:

views\application\_header.html.erb
#3

Adding the solution here for anyone else that reads this.

I am using Windows 10, 1809 and using Ubuntu linux directly in windows (with no VMs). Version 1903 is supposed to fix some of the ability for sharing files between windows and ubuntu, but I don’t have that version yet.

What was happening is I was creating everything perfectly in ubuntu, but then when I went to the hidden appdata folder in Windows and opened my folder structure in Sublime Text and started creating folders/files, etc. they weren’t showing up in Ubuntu bash.

As a workaround I’m now using /mnt/c/development/ and then building the test rails app there. This fixes the issues I was experiencing. There was nothing wrong with my render. Even though my editor showed I had the file in that location, on bash it was not actually there.