Renaming API when facing non standard decisions

I have noticed that currently there are non standard decisions in
Gdk:Display:

Gdk::Display#supports_shapes
Gdk::Display#supports_input_shapes

should be named:

Gdk::Display#supports_shapes?
Gdk::Display#supports_input_shapes?

because they return true or false. Is it ok to just rename them, or do
we want to maintain compatibility with these incorrect names? There
are not even documented on hiki, and probably seldom used, so I think
we should maybe just rename them without compatibility…


Guillaume C. - http://zarb.org/~gc/

Hi,

In [email protected]
“[ruby-gnome2-devel-en] renaming API when facing non standard
decisions” on Tue, 8 Apr 2008 16:04:53 +0200,
“Guillaume C.” [email protected] wrote:

because they return true or false. Is it ok to just rename them, or do
we want to maintain compatibility with these incorrect names? There
are not even documented on hiki, and probably seldom used, so I think
we should maybe just rename them without compatibility…

Ah, right. Please just rename.

Thanks,

kou

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs