Removing X11 dependency for Mac OS X builds of GNU Radio using Mac Ports

Hi Michael,
Have you considered removing the X11 dependency
for the Mac OS X version of GNU Radio from the Mac Ports build system?

Over the past 3 days, I’ve experimented with various hardware and
software combinations (iMac 27", Thinkpad T42p, Ubuntu 11.04 32-bit &
64-bit, Mac OS X 10.6.7).

About a year ago, if you recall, I managed to build GRC with GTK+
instead of X11, and also got wxwidgets to work with carbon (i think for
32-bit) and gnuradio. I think I shared the technote with the list
earlier. I can re-send if you would like, it a long list that manually
gives steps by step instructions to build it without using Mac Ports.

I’ve just done a fresh install of Mac OS X on my iMac. I have two
options:

a. use Mac Ports to build GNU Radio, but I don’t like seeing X11 windows
on Mac OS X because they look so primitive its a crime to run it and
work on X11 on Mac OS X.

b. try to rebuild GNU Radio 3.4.0 on Mac OS X, and see what the state of
the libraries are for supporting 64-bit cocoa for the key components
that affect the rendering of the windows on Mac OS X, which mostly boil
down to the Cario libraries and wxwidgets.

Is it possible, by any chance, to generate a list of all dependent
libraries and their versions, that Mac Ports uses to build the gnu radio
3.4.0 installation?

I can scan this list, and review it one by one, and try to rebuild gnu
radio, manually once again to get it to run without X11.

If I can have that manual procedure working, you could use that info to
update Mac Ports to get gnuradio to build, hopefully with native carbon
or cocoa, than GTK+ or X11.

Best regards,

Elvis D.

Hi Michael,

On May 18, 2011, at 10:24 PM, Michael D. wrote:

Hi Elvis - A few months back, I tried using using MacPorts to install everything
using +no_x11 and +quartz. It didn’t work, and I ran out of time to try debugging
the issue.

I solved this one, using my manual build process, using quartz and GTK+.

So, once I generate exact dependency list, I can try to reproduce it
with the newer versions of the dependent libraries for gnuradio-3.4.0.

That said, good luck & please do keep the list informed when you have questions
or successes!

The following configurations worked so far with the current
gnuradio/master and master-3.3 branches:

  1. IBM ThinkPad T42p, Ubuntu 11.04 32-bit, gnuradio-3.4.0. The audio
    sound card works best using the audio sink at 32KHz.

  2. Apple iMac 27" 11,1 hardware version, Ubuntu 11.04 64-bit installed
    natively on a separate 400GB partition, dual-booting with OS X &
    gnuradio-3.4.0. The audio sound card works best using the audio sink at
    48KHz. The decimation values have be adjusted accordingly, to prevent
    choppy audio. This was a problem that was eluding me for so long, and
    just figured the difference out only yesterday. Now at least I have raw
    access to the iMac’s quad-core processor without using virtualization
    and vmware fusion.

  3. Apple iMac 27", Mac OS X 10.6.7, gnuradio-3.3.x built manually
    (without mac ports) fails make check at gr_fir_ccf: using SSE, but audio
    dial-tone example works fine.

  4. Apple iMac 27", Mac OS X 10.6.7, gnuradio-3.4.x built manually
    (without mac ports), fails make check with the socket error, but audio
    dial-tone example does NOT work.

Best regards,

Elvis D.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs