Remote require (was A python question...)


#1

On 4/6/07, Luciano R. removed_email_address@domain.invalid wrote:

Hello, I happen to enjoy Python and Ruby.

Importing modules from zip files was proposed in PEP-273 [1]

Reading about importing from a zip file in Python made me think
whether I could do the same in ruby. A quick google search showed up
it can be done with rubyzip [1].

Then I thought: what about remote requires? (I don’t think right now
it could be really useful but it sounds interesting to play with). I
found several threads ([2], [3]) talking about a net-require module
coded by Tanaka A…

Couldn’t find any place to download the module (there are some urls to
RAA but the project is not there anymore) and haven’t received any
response from the author. I know it’s not difficult to do some proof
of concept, there’s even some code to do it in one of the threads
mentioned before, just wanted to see how it was done in net-require.

Anyone has used it or knows where to get it?

[1] http://rubyzip.sourceforge.net/files/lib/zip/ziprequire_rb.html
[2] http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-talk/150997
[3]
http://groups.google.com/group/comp.lang.ruby/browse_thread/thread/6a07ae8825da3d3f/7faea892fae5c0d0?lnk=st&rnum=8#7faea892fae5c0d0


#2

On 4/10/07, Luis P. removed_email_address@domain.invalid wrote:

it could be really useful but it sounds interesting to play with). I
found several threads ([2], [3]) talking about a net-require module
coded by Tanaka A…

You might want to check out Francis H.'s uri-require.
http://rubyforge.org/projects/urirequire/