Release 3.2 and ossie


#1

Hi all,
I’m trying to use OSSIE.0.7.1 with new release of gnuradio (3.2).
The building of gnuradio it’s ok, but when I attempt to build OSSIE, the
make of USRP component returns this error:

if g++ -DPACKAGE_NAME=“USRP” -DPACKAGE_TARNAME=“usrp”
-DPACKAGE_VERSION=“0.6.2” -DPACKAGE_STRING=“USRP\ 0.6.2”
-DPACKAGE_BUGREPORT="" -DPACKAGE=“usrp” -DVERSION=“0.6.2”
-DHAVE_SYS_WAIT_H=1 -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1
-DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1
-DHAVE_MEMORY_H=1
-DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1
-DHAVE_UNISTD_H=1
-DHAVE_FORK=1 -DHAVE_VFORK=1 -DHAVE_WORKING_VFORK=1
-DHAVE_WORKING_FORK=1
-DHAVE_LIBOMNIORB4=1 -DHAVE_LIBOMNIDYNAMIC4=1 -DHAVE_OMNIORB4_CORBA_H=1
-DHAVE_LIBUSRP=1 -DHAVE_USRP_STANDARD_H=1 -DHAVE_USRP_DBID_H=1
-DHAVE_USRP_PRIMS_H=1 -DHAVE_LIBSTANDARDINTERFACES=1
-DHAVE_STANDARDINTERFACES_COMPLEXSHORT_H=1 -I. -I. -Wall -g -O2
-I/usr/local/include -MT main.o -MD -MP -MF “.deps/main.Tpo” -c -o
main.o
test -f 'src/main.cpp' || echo './'src/main.cpp;
then mv -f “.deps/main.Tpo” “.deps/main.Po”; else rm -f
“.deps/main.Tpo”; exit 1; fi
In file included from src/flex.h:29,
from src/USRP.h:41,
from src/main.cpp:31:
src/db_base.h:30: error: redefinition of ‘class db_base’
/usr/local/include/db_base.h:46: error: previous definition of ‘class
db_base’
In file included from src/USRP.h:41,
from src/main.cpp:31:
src/flex.h:147: error: conflicting return type specified for ‘virtual
void
db_flex::set_gain(float)’
/usr/local/include/db_base.h:101: error: overriding ‘virtual bool
db_base::set_gain(float)’
src/flex.h:153: error: conflicting return type specified for ‘virtual
void
db_flex::select_rx_antenna(int)’
/usr/local/include/db_base.h:107: error: overriding ‘virtual bool
db_base::select_rx_antenna(int)’
src/flex.h:155: error: conflicting return type specified for ‘virtual
void
db_flex::set_auto_tr(bool)’
/usr/local/include/db_base.h:106: error: overriding ‘virtual bool
db_base::set_auto_tr(bool)’
src/flex.h:156: error: conflicting return type specified for ‘virtual
void
db_flex::set_enable(bool)’
/usr/local/include/db_base.h:105: error: overriding ‘virtual bool
db_base::set_enable(bool)’
In file included from src/USRP.h:43,
from src/main.cpp:31:
src/tvrx.h:38: error: conflicting return type specified for ‘virtual
void
tvrx::set_gain(float)’
/usr/local/include/db_base.h:101: error: overriding ‘virtual bool
db_base::set_gain(float)’
make: *** [main.o] Error 1

Could you help me to find a solution to this problem?
thank you,

Serenella


#2

Serenella Ferri De Collibus wrote:

Hi all,
I’m trying to use OSSIE.0.7.1 with new release of gnuradio (3.2).
The building of gnuradio it’s ok, but when I attempt to build OSSIE, the
make of USRP component returns this error:

src/tvrx.h:38: error: conflicting return type specified for ‘virtual void
tvrx::set_gain(float)’
/usr/local/include/db_base.h:101: error: overriding ‘virtual bool
db_base::set_gain(float)’
make: *** [main.o] Error 1

Could you help me to find a solution to this problem?
thank you,

The libusrp API has changed slightly. I asked this question on the
OSSINE list and was told they have fixed the code, but need to test if
before releasing it. They did not say when that would be.

Philip