Reg overrun problem

Hi

I was trying to run the benchmark_rx and benchmark_tx programs in the
gnuradio 3.5.0 version, in my college lab. But I saw that when I am
running
the benchmark_rx in one of the wireless nodes, it shows the ‘O’.

there are core i7 processors in the nodes, and I am not sure why this
overrun problem is occurring. Can anyone tell me why this error occurs
and
what I should do to overcome it?

Thanks


Regards

Shantharam Balasubramanian
MS in Electrical and Computer Engineering
Rutgers University
Ph:732-543-6863
Email:[email protected]

On 01/30/2012 09:41 AM, shantharam balasubramanian wrote:

Ahh, le benchmark. Its more a proof of concept that you can implement a
mac layer in gnuradio, and less so a benchmark of anything. :slight_smile:

Here is a description of overflow:
http://files.ettus.com/uhd_docs/manual/html/general.html#overflow-underflow-notes

Faster processing can help, better code can help (if you care to
optimize benchmark rx*), and if you have a network product, larger
socket buffer can help:
http://files.ettus.com/uhd_docs/manual/html/transport.html#resize-socket-buffers

Not sure what modulation you selected, I think there may have been a
weird issue with the FLL. Try the GMSK modulation option (which doesnt
use the FLL), and see how well it works for you.

If you are feeling adventurous, I have SIMD-optimized float
adder/multiplier on my “next” branch. I think there are a few of these
multiplier blocks in the path of benchmark rx. So I am curious to hear
of the performance improvement of said math blocks provides any
noticeable effect for you in the overall benchmark rx app.
http://gnuradio.org/cgit/jblum.git/

Cheers,
-Josh

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs