Redmine startup fails


#1

No problems starting redmine on MRI, but I get the following on JRuby
head:

\redmine>jruby script/server -e production
=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails 2.1.2 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
Exiting
d:/jruby/bin/…/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
require': no such file to load -- win32/service (MissingSourceFile) from d:/jruby/bin/../lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’ from D:/jruby/lib/ruby/gems/1.8/gems/activesupport-
2.1.2/lib/active_support/dependencies.rb: 510:in require' from D:/jruby/lib/ruby/gems/1.8/gems/activesupport- 2.1.2/lib/active_support/dependencies.rb: 355:innew_constants_in’
from D:/jruby/lib/ruby/gems/1.8/gems/activesupport-
2.1.2/lib/active_support/dependencies.rb: 510:in require' from D:/jruby/lib/ruby/gems/1.8/gems/mongrel_service- 0.1/lib/mongrel_service/init.rb:5 from D:/jruby/lib/ruby/gems/1.8/gems/mongrel_service- 0.1/lib/mongrel_service/init.rb:31:inrequire’ from
d:/jruby/bin/…/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
require' from D:/jruby/lib/ruby/gems/1.8/gems/activesupport- 2.1.2/lib/active_support/dependencies.rb: 510:inrequire’
… 18 levels…
from D:/jruby/lib/ruby/gems/1.8/gems/rails-
2.1.2/lib/commands/server.rb:31:in require' from d:/jruby/bin/../lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’ from script/server:3

custome_require.rb didn’t provide much help other than indicating that a
source file is probably missing (as does the above). Wondered if it was
anything to do with rubygems, but that all seems to be up to date.

ANy ideas? Thanks.


Cheers,
Marc


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#2

That looks like it’s looking for service.rb in the win32 folder. Having
no experience with Redmine, I’m not sure if such a folder exists, and if
it does if it has a service.rb in it. That’s where I’d start looking,
though.

marc wrote:

`require’: no such file to load – win32/service (MissingSourceFile)
from D:/jruby/lib/ruby/gems/1.8/gems/mongrel_service-

custome_require.rb didn’t provide much help other than indicating that a
source file is probably missing (as does the above). Wondered if it was
anything to do with rubygems, but that all seems to be up to date.

ANy ideas? Thanks.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#3

marc wrote:

No problems starting redmine on MRI, but I get the following on JRuby
head:

If RedMine has added a dependency on win32, they should be thoroughly
slapped around. It appears that they have. Complain to RedMine :slight_smile:

  • Charlie

To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#4

Charles Oliver N. said…

marc wrote:

No problems starting redmine on MRI, but I get the following on JRuby
head:

If RedMine has added a dependency on win32, they should be thoroughly
slapped around. It appears that they have. Complain to RedMine :slight_smile:

Thanks guys. I’ll get onto them and report back.


Cheers,
Marc


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#5

Arun G. said…

FWIW, Redmine used to work fine on JRuby/GlassFish as described at:

http://blogs.sun.com/arungupta/entry/redmine_on_glassfish_ruby_on

Thanks. I’ve not tried to deploy on Glassfish, but will do over the
weekend.

Thanks guys. I’ll get onto them and report back.


Cheers,
Marc


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#6

Arun G. said…

FWIW, Redmine used to work fine on JRuby/GlassFish as described at:

http://blogs.sun.com/arungupta/entry/redmine_on_glassfish_ruby_on

Just to say that Redmine works fine with JRuby HEAD on Glassfish3 from
within Netbeans. Since it also runs under Webrick, the only failure is
under mongrel.

Thanks guys. I’ll get onto them and report back.


Cheers,
Marc


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#7

FWIW, Redmine used to work fine on JRuby/GlassFish as described at:

http://blogs.sun.com/arungupta/entry/redmine_on_glassfish_ruby_on

-Arun

marc wrote:

Charles Oliver N. said…

marc wrote:

No problems starting redmine on MRI, but I get the following on JRuby
head:
If RedMine has added a dependency on win32, they should be thoroughly
slapped around. It appears that they have. Complain to RedMine :slight_smile:

Thanks guys. I’ll get onto them and report back.


Application Platform, Sun Microsystems, Inc.
Blog: http://blogs.sun.com/arungupta


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#8

Arun G. said…

All the more reason to use GlassFish instead of Mongrel :wink:

:slight_smile: No problem with that, but mongrel does start up a lot quicker when
testing in nb. I’m deploying on Glassfish, but it sure uses a lot of
memory.

And just to add to the detail: I eventually got Redmine deployed on
Glassfish outside Netbeans - both standalone and as a war. It took a bit
of fiddling, though.

marc wrote:

Charles Oliver N. said…

marc wrote:

No problems starting redmine on MRI, but I get the following on JRuby
head:
If RedMine has added a dependency on win32, they should be thoroughly
slapped around. It appears that they have. Complain to RedMine :slight_smile:
Thanks guys. I’ll get onto them and report back.


Cheers,
Marc


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#9

All the more reason to use GlassFish instead of Mongrel :wink:

-Arun

marc wrote:

-Arun


Application Platform, Sun Microsystems, Inc.
Blog: http://blogs.sun.com/arungupta


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email