RedCloth on Windows


#1

How to Install RedCloth on Windows?

The usual way fails:

gem install RedCloth

Building native extensions. This could take a while…

ERROR: Error installing RedCloth:

    ERROR: Failed to build gem native extension.

C:/Ruby/bin/ruby.exe extconf.rb

creating Makefile

make

‘make’ is not recognized as an internal or external command,

operable program or batch file.

Gem files will remain installed in
C:/Ruby/lib/ruby/gems/1.8/gems/RedCloth-4.2.2

for inspection.

Results logged to
C:/Ruby/lib/ruby/gems/1.8/gems/RedCloth-4.2.2/ext/redcloth_sca

n/gem_make.out

I tried with Cygwin, but I think I messed up the Cygwin install or
setup, since

$ gem install RedCloth

Gives:

C:\Ruby\bin\ruby.exe: No such file or directory –
/cygdrive/c/Ruby/bin/gem

I issued gem install RedCloth on Linux and it worked. I copied the
files, but I can’t use them on windows. Since NetBeans IDE gives Missing
these required gems: RedCloth

Other gems work. Only RedCloth does not.

Any idea what to do?

Thanks a lot,

Peter

c


#2

Any idea what to do?

I don’t know what Windows version of Ruby you’re using, but I’m able to
successfully use RedCloth using the RubyInstaller from
http://rubyinstaller.org/ in combination with the MSys/MinGW DevKit
DevKit from
http://wiki.github.com/oneclick/rubyinstaller/development-kit

In a nutshell, this combination enables Windows users to compile many of
the native C-based extensions that either don’t currently offer a
mingw32 binary gem or no binary gems period. FYI, we maintain a list of
the status of many of the native C-based gems that work or don’t work
with the above environment at
http://wiki.github.com/oneclick/rubyinstaller/gem-list

My environment…

C:\Users\Jon\Documents>ruby --version
ruby 1.9.1p378 (2010-01-10 revision 26273) [i386-mingw32]

C:\Users\Jon\Documents>gem --version
1.3.5

C:\Users\Jon\Documents>gem list RedCloth -d

*** LOCAL GEMS ***

RedCloth (4.2.2)
Author: Jason G.
Rubyforge: http://rubyforge.org/projects/redcloth
Homepage: http://redcloth.org
Installed at: C:/ruby191/lib/ruby/gems/1.9.1

RedCloth-4.2.2 - Textile parser for Ruby. http://redcloth.org/

#3

Thanks a lot, I tried with Cygwin, but this is a lot easier, and work.
Why I had to do the hard way?!
Thanks again,
Problem solved.
Peter


#4

You might say something about the specific version(s)
you were using: of Windows, Ruby, anything else?

I installed the RedCloth gem with no problems a few months ago

  • on a Windows 2000 system
  • with Ruby 1.8.6 (2008-08-11 patchlevel 287) [i386-mswin32]

Because I wanted to use webby, I installed the webby gem first:
gem install webby
gem install RedCloth

The version of RedCloth?
The directory in the gems/1.8 dir is named
RedCloth-4.2.2-x86-mswin32-60
The directories are dated 2009-09-19, files 2009-09-21

So, this is my non-bug report. :slight_smile: