Receiving signal from a signal generator

Hi,
I’ve got 2 units of USRP1 and DBSRX dboards. The two USRP are
synchronized for master and slave. the uhd_fft.py is responding
correctly.
Now I want to use a signal generator to provide 900 MHz. signal level is
-20 dBm. From the gnuradio-companion, I created a flow graph using
UHD-USRP Source connected to WX-GUI-FFT Sink. The setup are as follow:
For USRP source:
ID: uhd_usrp_source_0
Device Addr: fpga=usrp1_fpga_4rx.rbf
Sync: Don’y sink
Clock rate: default
Num Mboards:1
Mbo Clock source: default
Mbo Time source:default
Mbo Subdevice Spec:
Num Channel: 1
Sample rate (sps): 32K
Cho Center freq: 900M
Cho Gain:30 dB
Cho Antenna: RXA
Cho Bandwidth:10M

For FFT Sink:
Sample rate:32k
Baseband freq:900M

With this setup, only noise is plotted in the FFT. I don’t see the
signal at 900MHz. And even if I remove the daughterboard from the usrp,
the result is unchanged: Noise only.
Can you please tell me what is wrong with the setup, and what to do if I
want to use the side B. Also which USRP must I use: the master, the
slave or both. Please help.

On Fri, Feb 17, 2012 at 2:52 AM, guelord ingala
[email protected]wrote:

    Clock rate: default

I think your sample rate is way too low for the USRP. When you run the
program, you should see a warning being printed that you tried to set
the
sample rate to 32 kHz but the actual sample rate was something else.
This
could cause some confusion in your setup.

Also, make sure that you are going into the right antenna port on the
USRP.

Finally, a -20 dBm signal and 30 dB of gain in the USRP is a really loud
signal. You might be swamping your front end. I’d put the input signal
down
to -50 dBm to start with and lower the gain. Up the gain slowly as
necessary.

Tom

On Fri, Feb 17, 2012 at 10:22 AM, Tom R. [email protected] wrote:

    Device Addr: fpga=usrp1_fpga_4rx.rbf
    Cho Antenna: RXA

want to use the side B. Also which USRP must I use: the master, the slave
Finally, a -20 dBm signal and 30 dB of gain in the USRP is a really loud
signal. You might be swamping your front end. I’d put the input signal down
to -50 dBm to start with and lower the gain. Up the gain slowly as
necessary.

One other potential issue here: if you’re tuning the LO to 900 MHz, and
injecting a tone at exactly 900 MHz from a signal generator, the signal
downconverted signal would end up sitting exactly at DC, and may be
removed
by DC offset correction if it is enabled. Once you’ve widened up your
sample rate a bit per Tom’s suggestion (try something on the order of a
couple of MHz, or whatever decimation ratio would get you to something
in
this range), try offsetting your input tone to 900.1 MHz and see if it
shows up.

John

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs