Receiving Authentication Error

Hi. A newbie. I installed/upgraded all the proper (at least that I know
of) apps needed to run ruby on rails on a mac, but keep receiving mysql
errors. The default page works fine, but as soon as I try a simple
“hello world” controller that I’m testing, I keep getting different
errors.

Current one after researching forums and trying to troubleshoot the
problem, I’m stuck on a “Status: 500 Internal Server Error
Client does not support authentication protocol requested by server;
consider upgrading MySQL client” I am upgraded to the latest. What
gives? And I did assign a password to the root and "sudo gem install
mysql – --with-mysql-dir=/usr/local/mysql’

My mac is os x 10.5.7
Ruby 1.8.7
Rails 2.3.3
Gem 1.3.5
MySQL 5.1.37

Here’s an excerpt copy of the error from the development.log:
!\ FAILSAFE /!\ Tue Aug 04 08:10:08 -0700 2009
Status: 500 Internal Server Error
Client does not support authentication protocol requested by server;
consider upgrading MySQL client
/usr/local/lib/ruby/1.8/mysql.rb:453:in read' /usr/local/lib/ruby/1.8/mysql.rb:130:inreal_connect’
/usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.3/lib/active_record/connection_adapters/mysql_adapter.rb:576:in
connect' /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.3/lib/active_record/connection_adapters/mysql_adapter.rb:204:ininitialize’

I have also properly updated the database.yml and have added the root
password

Any thoughts? Appreciated.

Did you build the mysql gem with the correct version of the mysql
client library? try the – --with-mysql-config=/path_to/mysql_config
option and make sure it is the right version?

On Aug 4, 8:54 pm, Mosses A. [email protected]

Thanks Mukund- but that didn’t do the trick either. This is what I did:
sudo gem install mysql –
–with-mysql-config=/usr/local/mysql-5.1.37-osx10.5-x86/bin/mysql-config

Even went back and tried:
sudo gem install mysql –
–with-mysql-dir=/usr/local/mysql-5.1.37-osx10.5-x86

Unfortunately nothing. Any other suggestions would be appreciated. I’ve
been tackling this for few days now and can’t seem to resolve it. :frowning:

On Aug 4, 4:54 pm, Mosses A. [email protected]
wrote:

gives? And I did assign a password to the root and "sudo gem install
mysql – --with-mysql-dir=/usr/local/mysql’

Well for some reason you’re not using the gem you built - it’s falling
back to a pure ruby version of the mysql driver ( in /usr/local/lib/
ruby/1.8/mysql.rb ) which by the sounds of it is rather old (either
that or it is finding the pure ruby one first - can’t remember in what
order ruby will find things)

Fred

@raul

I got it to work barely yesterday night. I took someone’s advice off of
another forum and re-installed Xcode from Apple. Then I upgraded MySQL
again since I had downgraded due to testing different versions. For some
reason this time around it finally worked.

Good luck!

Mosses,

Did you had any luck? I am having the same problem. It does not happen
when I connect to localhost as root it only happend on a remote server
though. I tried multiple versions of mysql, 5+ and multiple ways of
installing mysql gem without any luck.

On Aug 5, 5:39 pm, Mosses A. [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs