Really disappointed

I can’t work :frowning:

Using mongrel (1.1.5)
Using normalize_attributes (0.1.6)
Using rails (3.0.7)
System.java:-2:in arraycopy': java.lang.ArrayIndexOutOfBoundsException from DefaultResolver.java:111:inmakeTime’
from DefaultResolver.java:277:in create' from DefaultResolver.java:317:inhandleScalar’
from DefaultResolver.java:435:in orgHandler' from DefaultResolver.java:455:innode_import’
from DefaultResolver$s$1$0$node_import.gen:65535:in call' from CachingCallSite.java:137:incall’
from RubyLoadHandler.java:40:in handle' from Parser.java:300:inaddNode’
from DefaultYAMLParser.java:676:in yyparse' from Parser.java:290:inyechtparse’
from Parser.java:284:in parse' from YParser.java:152:inload’
from YParser$s$0$1$load.gen:65535:in call' from JavaMethod.java:630:incall’

Hi Mauro,

We ran into this issue last night. In our case it seemed to be related
to
RSpec 2.6. We changed Gemfile to bundle 2.4 instead and it worked. You
might
want to try different versions of your gems and/or a different
repository.

On 20 May 2011 21:46, Rohit N. [email protected] wrote:

Hi Mauro,

We ran into this issue last night. In our case it seemed to be related to
RSpec 2.6. We changed Gemfile to bundle 2.4 instead and it worked. You might
want to try different versions of your gems and/or a different repository.

platforms :jruby do
gem ‘activerecord-jdbc-adapter’
gem ‘arel’, ‘2.0.9’
gem ‘rspec’, ‘~> 2.4’

But not solved :frowning:

On 20 May 2011 21:35, Mauro [email protected] wrote:

   from DefaultResolver.java:435:in `orgHandler'
   from JavaMethod.java:630:in `call'

…and I have gem ‘arel’, ‘2.0.9’ in my Gemfile.

Hi Mauro,

On May 20, 2011, at 4:58 PM, Mauro wrote:

gem ‘rspec’, ‘~> 2.4’
The problematic rspec 2.6 will still be matched by that version
specification – ~>2.4 means >= 2.4 && < 3.0. The actual problem is with
rspec-core 2.6.1, so putting rspec-core 2.6.0 in your Gemfile is a
workaround if your problem is with rspec.

If it isn’t with rspec, it could be any of your dependencies that has
had a recent release and which isn’t locked down. The best way to narrow
it down is to try installing each one with the version restriction in
your Gemfile and see what fails. Then lock that gem to the previous
release.

Rhett

On 20 May 2011 21:58, Mauro [email protected] wrote:

gem ‘rspec’, ‘~> 2.4’

But not solved :frowning:

Here is my Gemfile:

source ‘http://rubygems.org

gem ‘rails’
gem ‘compass’
gem ‘will_paginate’, ‘~> 3.0.pre2’
gem ‘annotate’
gem ‘normalize_attributes’
gem ‘haml-rails’
gem ‘jquery-rails’
gem ‘devise’
gem ‘meta_where’
gem ‘simple_form’
gem ‘fastercsv’
gem ‘inherited_resources’
gem ‘inherited_resources_views’
gem ‘rails_config’
gem ‘simple-navigation’
gem ‘mongrel’

platforms :jruby do
gem ‘activerecord-jdbc-adapter’
gem ‘arel’, ‘2.0.9’
gem ‘rspec’, ‘~> 2.4’
gem ‘jdbc-postgres’
gem ‘jruby-openssl’
gem ‘warbler’
end

group :development, :test do
gem ‘rspec-rails’
gem ‘cucumber-rails’
gem ‘capybara’
gem ‘launchy’
gem ‘autotest’
gem ‘autotest-notification’
gem ‘database_cleaner’
gem ‘spork’, ‘~> 0.9.0.rc’
gem ‘machinist’, ‘>= 2.0.0.beta1’
gem ‘faker’
end

group :development do
gem ‘hpricot’
gem ‘ruby_parser’
end

On 20 May 2011 22:03, Rhett S. [email protected] wrote:

platforms :jruby do
gem ‘activerecord-jdbc-adapter’
gem ‘arel’, ‘2.0.9’
gem ‘rspec’, ‘~> 2.4’

The problematic rspec 2.6 will still be matched by that version specification –
~>2.4 means >= 2.4 && < 3.0. The actual problem is with rspec-core 2.6.1, so
putting rspec-core 2.6.0 in your Gemfile is a workaround if your problem is with
rspec.

If it isn’t with rspec, it could be any of your dependencies that has had a
recent release and which isn’t locked down. The best way to narrow it down is to
try installing each one with the version restriction in your Gemfile and see what
fails. Then lock that gem to the previous release.

But I have a lot of gems, I should try each one?
I’m really really disappointed because this bad bug.

On 20 May 2011 22:12, Lenny M. [email protected] wrote:

The Gemfile.lock file would be better to tell exactly what gems you wind up with
based on your Gemfile.

You have requested:
arel = 2.0.9

The bundle currently has arel locked at 2.0.10.
Try running bundle update arel

On May 20, 2011, at 6:03 PM, Mauro wrote:

gem ‘arel’, ‘2.0.9’
gem ‘rspec’, ‘~> 2.4’

But not solved :frowning:

Here is my Gemfile:

The Gemfile.lock file would be better to tell exactly what gems you wind
up with based on your Gemfile.

-lenny

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs