Re: WYMeditor breaking on popup windows

Hi All,

First, thanks for making the WymEditor extension for Radiant Benny! I
find fckeditor and tinymce a massive pain, both to de-crapify and in
the code they produce, so this was welcome.

Ie$B!Ge(Bm doing some testing before showing a site to a client, and
Ie$B!Ge(Bve got a problem in that on any page that has an uploaded
page_attachment, any of the buttons that activate pop-up windows
(image, link etc) also replace the body of the admin page with this:

 /^([\s<\/>]*)|([\s<\/>]*)$/gm

so under the popup window my page is now only the red header and the
gray footer, and one line of regex in the middle. Has anyone else come
across this?

Ie$B!Ge(Bm running on 0.6.7 frozen to edge (svn rev 881), and I got the
WYMeditor extension via a github clone. When trying to insert a
page_attachments image I can drag and drop the file icon to include
that, or the file name to make a link, but Ie$B!Ge(Bm specifically
wanting to be able to add the full-size image with alt text, which
requires the popup. Does anyone know why this is happening, and how I
can fix it?

peace - oli

I am sorry to hijack this thread, but something in your post has me
scratching my head. In your post, you said

When trying to insert a page_attachments image
I can drag and drop the file icon to include that, or the file name to make
a link

Drag and drop what file icon and what link? Do you mean the link that
shows up in the Attachments area? I tried that, and it doesn’t seem
to work. Is there something you need to do to get that to work?

Again, sorry to hijack this thread and I don’t have an answer to your
question.

Jason

2008/7/23 Oli S. [email protected]:

Yes, I’m getting this behavior as well. But haven’t had a chance to
look into it.

Cheers,
Nicholas

2008/7/24 Oli S. [email protected]:

Yes, I’m getting this behavior as well. But haven’t had a chance to
look into it.

Cheers,
Nicholas

2008/7/24 Oli S. [email protected]:

Hey Jason,

On Aug 12, 2008, at 2:48 PM, jsmorris wrote:

Drag and drop what file icon and what link? Do you mean the link that
shows up in the Attachments area? I tried that, and it doesn’t seem
to work. Is there something you need to do to get that to work?

This is the icon and link that the page_attachments extension adds to
the bottom of an article edit page, after youe$B!Ge(Bve used it to
upload an image. Normally with the input filter set to a default input
dragging and dropping one of these inserts either an img tag
(thumbnail) or a link (filename). Ie$B!Ge(Bm not sure if by
e$B!He(Battachments areae$B!Ie(B you mean something in WYMeditor or
page_attachments, but drag and drop should work with page_attachments
and a default filter.

On Aug 13, 2008, at 1:25 AM, Nicholas H. wrote:

Yes, I’m getting this behavior as well

Glad ite$B!Ge(Bs not just me. Ie$B!Ge(Bm using FCKeditor for the
moment, although that has no page_attachments integration, and the
inbuilt image management features are a bit opaque. It sounds like
integrating it with page_attachments or giving it page_attachments-
like abilities would both be a lot of work though.

peace - oli

Oli - did you find a fix for this?

2008/8/13 Oli S. [email protected]:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs