Re: WX GUI Errors on MacOS

I’m running MacOS 10.8.2 and have no controls for my waterfall sink and
the
constellation sink was yelling, “No module named OpenGL”. I installed
py27-opengl thinking it was an issue with the wrapper, but now all my
widgets show the error Steven was having in April:

http://lists.gnu.org/archive/html/discuss-gnuradio/2012-04/msg00578.html

“/usr/local/lib/python2.7/site-packages/gnuradio/wxgui/plotter/plotter_base.
py”,
line 58, in draw
GL.glNewList(self._grid_compiled_list_id, GL.GL_COMPILE)
ctypes.ArgumentError: argument 1: <type ‘exceptions.TypeError’>: wrong
type

Other reading suggests there may not be an OpenGL context when
plotter_base.py calls the glNewList command; but I’m not much of an
OpenGL
expert. Any thoughts or direction, this one’s been haunting me for a few
days. Thanks!

-David

On Thu, Jan 17, 2013 at 3:05 PM, David G. [email protected]
wrote:

line 58, in draw
GL.glNewList(self._grid_compiled_list_id, GL.GL_COMPILE)
ctypes.ArgumentError: argument 1: <type ‘exceptions.TypeError’>: wrong type

Other reading suggests there may not be an OpenGL context when
plotter_base.py calls the glNewList command; but I’m not much of an OpenGL
expert. Any thoughts or direction, this one’s been haunting me for a few
days. Thanks!

-David

Just turn off the OpenGL stuff. Look in
$prefix/etc/gnuradio/conf.d/gr-wxgui.conf and set ‘style=nongl’.

Tom

“Just turn off the OpenGL stuff. Look in
$prefix/etc/gnuradio/conf.d/gr-wxgui.conf and set ‘style=nongl’.”

Thanks for the suggestion Tom, but I’ve already given this a shot with
no
luck, as well as making sure my ~/.gnuradio/config.conf was also set to
nongl.

  • When I have py27-opengl active, I get the plotter_base.py ‘wrong
    type’
    error for all my widgets.

  • When I deactivate py27-opengl, and change the configuration to nongl,
    I
    get no constellation plot and missing controls (all blue) for the
    waterfall.

-David

“Have you tried using the gr-qtgui sinks?”

The QT GUI sink works great, and I’ll have to stick with that from now
on. I
really liked the wxgui interface from using gnuradio in ubuntu, and
figured
I’d take a shot at fixing it on the mac.

Thanks anyway,

-David

On Thu, Jan 17, 2013 at 3:30 PM, David G. [email protected]
wrote:

  • When I deactivate py27-opengl, and change the configuration to nongl, I
    get no constellation plot and missing controls (all blue) for the
    waterfall.

-David

Have you tried using the gr-qtgui sinks? You’ll have to roll your own
application as right now all our main apps use wxgui, but that might
work
better for you.

Tom

David, I’m having the same problem with OpenGL and WX GUI on a Mac,
please let me know if you sort this out.

Thanks
V.

Valentin Goverdovsky wrote in post #1098465:

David, I’m having the same problem with OpenGL and WX GUI on a Mac,
please let me know if you sort this out.

Thanks
V.

I am having the same problem too with the same configuration.
Greg

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs