Re: Where is libopenssl-ruby - For Rails install - UPDATED!


#1

On Tue, Oct 21, 2008 at 5:18 PM, Hugh S. removed_email_address@domain.invalid wrote:

libopenssl-ruby.I am running LINUX Suse: 2.6.16.21-0.8-smp
Ruby S.
fact.
Thank you

    Hugh

Well Team, you might be correct!That been said, I got this error while
installing Rails under Suze. To be precise, I am copying below the
actual
errors.
The problem is that I performed a google search and the results was to
get
the libopenssl-ruby library.
Any help is greatly appreciated!

nyc-linux-suse170:/local/demo # ruby script/server
=> Booting WEBrick…
/usr/local/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/initializer.rb:229:in
require_frameworks': no such file to load -- openssl (RuntimeError) from /usr/local/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/initializer.rb:118:inprocess’
from
/usr/local/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/initializer.rb:97:in
send' from /usr/local/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/initializer.rb:97:inrun’
from /local/demo/config/environment.rb:13
from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require' from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.1.1/lib/active_support/dependencies.rb:510:in
require' from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.1.1/lib/active_support/dependencies.rb:355:innew_constants_in’
… 7 levels…
from
/usr/local/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/commands/server.rb:39
from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require' from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from script/server:3

Thank you


#2

On Thu, 23 Oct 2008, Ruby S. wrote:

While installing Rails, I came across the fact that I need this

The problem is that I performed a google search and the results was to get
the libopenssl-ruby library.
Any help is greatly appreciated!

man rpm includes on its first page:
INSTALLING, UPGRADING, AND REMOVING PACKAGES:
rpm {-i|–install} [install-options] PACKAGE_FILE …

http://tinyurl.com/n6bbh

nyc-linux-suse170:/local/demo # ruby script/server
=> Booting WEBrick…
/usr/local/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/initializer.rb:229:in
`require_frameworks’: no such file to load – openssl (RuntimeError)

Yes, its a missing library.

    Hugh