Re: Warbler + Bundler problem: "can't find executable bundle"

Sorry for the top-posted reply but my phone gives no other options and
I’m away right now. I ran into that a while back. For some reason the
bundled Bundler had a mangled gem specification with a bad (almost
empty) files line. Try making sure you have an up to date RubyGems (gem
update --system) and do a bundle install --deployment before building
your WAR.

-lenny

Sent from my phone

----- Reply message -----
From: “Francisco V.” [email protected]
Date: Thu, Sep 29, 2011 9:45 am
Subject: [jruby-user] Warbler + Bundler problem: “can’t find executable
bundle”
To: [email protected]

Hi, I am using warbler 1.3.2 to package a rails 2.3.11 app that uses
jruby 1.5.6 and bundler 1.0.20. When I deploy to Tomcat 6.0.29 on RedHat
5 I get a “can’t find executable bundle for bundler-1.0.20” exception
when tomcat is running the preinitializer.rb file that bundler needs
http://gembundler.com/rails23.html for rails 2.3 apps.

Seems that the gems are packaged correctly and Tomcat can find the
bundler gem, but it can not find the bundle executable that lives in the
bin folder of the gem. I have tried both packing my gems in a jar file
and using the config.gem_path configuration in warble.rb but in both
cases I get the same error.

Is there any warble setting that I need to use so Tomcat can find the
executables for the gems I have packed with warbler?

I am attaching my stack trace with a bunch of debugging info

Attachments:
http://www.ruby-forum.com/attachment/6638/stack.txt


Posted via http://www.ruby-forum.com/.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs