Re: Volk machine

Nick:

I tried downsampling the 25MHz to 10, but still was not recording the
whole
time I ran (about 10 seconds, with only a couple seconds of playback).
That
was when I tried using a RAM disk, albeit at 50 downsampled to 30. I am
using the following for my disk:

mount -o size=1G -t tmpfs none /mnt/tmpfs

I then store my data file to /mnt/tmpfs

Am I doing that wrong? Or is there some other explanation for not
storing
data (other than storage size)?

Again, all feedback and help is appreciated.

Nick F. [email protected] wrote:

Paul,

30MHz is a big chunk of data to be streaming to anything. A 4GB ramdisk
will be full in 30 seconds at this rate. Do you really not know a
priori
where
in the whole 0-30MHz spectrum your signal will be?

I notice now in your first post that you’re streaming 25Msps with a
low-pass filter to 10MHz – if this is the case, why use a 25Msps rate
in
the first place? You can make the USRP work for you by asking for 10Msps
(or less, if you know you need less bandwidth) – it’ll handle the
downsampling and filtering.

–n

What was the size of the recorded file on the RAM disk? Are you seeing
“O”
indications (for overflow)?

–n

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs