What about Range#include?? Would it still be an
alias for Range#member?, or would it retain the
current interval check?
No decided yet. Feel free to say your opinion.
Well, I tend to agree with your previous decision on this. Having
Enumerable#include? be an alias for Enumerable#member? (or vice-versa),
but having Range#include? behave differently from Range#member? would be
confusing. I think it would be better to leave these two methods as
aliases and add a new method to Range for the interval check. My
leading candidate for this method is now David A. Black’s suggestion of
#encompass?. This is a great name and I really like his idea of
extending it to accept Ranges as parameters so that
(1…10).encompass?(2…9) == true. Other synonyms could also work:
#enclose?, #surround?, and even #contain?.
- Warren B.