Re: Sending pre-saved OFDM file to USRP

Thank you for your reply, Tom.

With the ‘’ and ‘’, I receive
the right packets using the command:

$ ./ -T A -f 2.45G -i 512
$ ./ -R A -f 2.45G -d 256

But when I send the pre-saved file (which is saved from the
‘’), the ‘’ does not detect any
packet at the receiver side.

Viewing the received signal with, I see the same spectrum,
as from the ‘’ sent spectrum, though.

I send it with the same frequency, with the same interpolation rate, and
with the same gain value…

----- Original Message ----
From: Tom R. [email protected]
To: Hoo-chang Shin [email protected]
Cc: [email protected]
Sent: Thursday, April 17, 2008 5:03:14 PM
Subject: Re: [Discuss-gnuradio] Sending pre-saved OFDM file to USRP

Hoo-chang Shin wrote:

Well, I did it like that, it did not work with connecting the file_source direct to USRP.
I thought then it might work when I do the ‘vector thing’ in the middle.
In either case, the receiver USRP does not detect anything.

Have you tried to run at the receiver to make sure you see
some energy?

Also, have you just tried using on one side and on another?

There are a lot of parameters to tweak. The amplitude is one important
one (high enough to be seen at the receiver, low enough to avoid
clipping), and the decim/interp values depend on the speed of your

FWIW, just saying the receiver isn’t getting anything isn’t too useful
when asking for help with all of the possible issues.


filename = 'tx_usrp_data.dat'

Why don’t you just do:

self.connect(src, self.u)

Instead of all the vector stuff in the middle?



Be a better friend, newshound, and
know-it-all with Yahoo! Mobile. Try it now.;_ylt=Ahu06i62sR8HDtDypao8Wcj9tAcJ

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs