[RE][RE][RE] i am getting errors when run these commands

I am using ubuntu 10.04.1 …
I want to run my coupa application

all required gems FOR COUPA-1.5 are

  1. gem install rails –v 1.2.3 ------------------------------ But i have
    installed gem install rails (2.3.8)
  2. gem install ferret –v 0.11.4 ------------------------------ But i
    have
    installed gem install sdsykes-ferret (0.11.6.19)
  3. gem install -y -v 0.4.1 acts_as_ferret
  4. gem install rtf
  5. gem install mysql
  6. gem install vpim
  7. gem install rake –v 0.7.3
  8. gem install mongrel
  9. gem uninstall rake –v 0.8.1 (or any other version of rake that is
    currently
    on your system. Type “gem list” to see all gems and their version)

XXXXXXXXXX:~/.coupa-1.5#gem list
*** LOCAL GEMS ***

actionmailer (2.3.8)
actionpack (2.3.8)
activerecord (2.3.8)
activeresource (2.3.8)
activesupport (2.3.8)
acts_as_ferret (0.4.1)
daemons (1.0.10)
gem_plugin (0.2.3)
gemsonrails (0.7.2)
minitest (1.6.0)
mongrel (1.2.0.pre2)
mysql (2.8.1)
rack (1.1.0)
rails (2.3.8)
rake (0.8.7)
rdoc (2.5.8)
rtf (0.1.0)
rubygems-update (1.3.7)
rvm (0.1.45)
sdsykes-ferret (0.11.6.19)
test-unit (2.1.1)
vpim (0.695)

XXXXXXXXX:~/.coupa-1.5# mongrel_rails start
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment…
Your config/boot.rb is outdated: Run “rake rails:update”.

XXXXXXXXX:~/.coupa-1.5# rake rails:update
(in /root/.coupa-1.5)
DEPRECATION WARNING: Rake tasks in vendor/plugins/backgroundrb/
tasks,
vendor/plugins/blueprint/tasks, vendor/plugins/coupa_engine/tasks,
vendor/plugins/deprecated/tasks, vendor/plugins/engines/tasks, vendor/
plugins/human_attribute_override/tasks, vendor/plugins/scoped_access/
tasks, vendor/plugins/selenium-on-rails/tasks, and vendor/plugins/
user_engine/tasks are deprecated. Use lib/tasks instead. (called from
<top (required)> at /usr/local/lib/ruby/gems/1.9.1/gems/rails-2.3.8/
lib/tasks/rails.rb:10)
rake aborted!
no such file to load – yaml/encoding
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.8/lib/
active_support/dependencies.rb:156:in require' /usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.8/lib/ active_support/dependencies.rb:156:inblock in require’
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.8/lib/
active_support/dependencies.rb:521:in new_constants_in' /usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.8/lib/ active_support/dependencies.rb:156:inrequire’
/root/.coupa-1.5/vendor/plugins/coupa_engine/tasks/coupa_engine.rake:
31:in block (2 levels) in <top (required)>' /usr/local/lib/ruby/1.9.1/rake.rb:1874:inin_namespace’
/usr/local/lib/ruby/1.9.1/rake.rb:908:in namespace' /root/.coupa-1.5/vendor/plugins/coupa_engine/tasks/coupa_engine.rake: 21:inblock in <top (required)>’
/usr/local/lib/ruby/1.9.1/rake.rb:1874:in in_namespace' /usr/local/lib/ruby/1.9.1/rake.rb:908:innamespace’
/root/.coupa-1.5/vendor/plugins/coupa_engine/tasks/coupa_engine.rake:
17:in <top (required)>' /usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.8/lib/ active_support/dependencies.rb:145:inload’
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.8/lib/
active_support/dependencies.rb:145:in block in load_with_new_constant_marking' /usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.8/lib/ active_support/dependencies.rb:521:innew_constants_in’
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.8/lib/
active_support/dependencies.rb:145:in load_with_new_constant_marking' /usr/local/lib/ruby/gems/1.9.1/gems/rails-2.3.8/lib/tasks/rails.rb: 11:inblock in <top (required)>’
/usr/local/lib/ruby/gems/1.9.1/gems/rails-2.3.8/lib/tasks/rails.rb:
11:in each' /usr/local/lib/ruby/gems/1.9.1/gems/rails-2.3.8/lib/tasks/rails.rb: 11:in<top (required)>’
/root/.coupa-1.5/Rakefile.rb:10:in require' /root/.coupa-1.5/Rakefile.rb:10:in<top (required)>’
/usr/local/lib/ruby/1.9.1/rake.rb:2373:in load' /usr/local/lib/ruby/1.9.1/rake.rb:2373:inraw_load_rakefile’
/usr/local/lib/ruby/1.9.1/rake.rb:2007:in block in load_rakefile' /usr/local/lib/ruby/1.9.1/rake.rb:2058:instandard_exception_handling’
/usr/local/lib/ruby/1.9.1/rake.rb:2006:in load_rakefile' /usr/local/lib/ruby/1.9.1/rake.rb:1991:inrun’
/usr/local/bin/rake:31:in `’

if i run any rake command i get same
errors…

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs