Re: Re: IO Error


#1
I might have seen this recently.

However I'm in the middle of tracking down a multithreaded issue (not sure if it's rails 2.2. or Jruby... I'm thinking rails but I'm having a bugger of a time tracking it down and I'm not getting much input from the rails guys.)

The issue I'm seeing  under a load test where I log in and log out repeatedly is:

[#|2008-12-11T16:14:13.299-0500|INFO|sun-appserver9.1|javax.enterprise.system.container.web|_ThreadID=16;_ThreadName=httpWorkerThread-8081-1;|PWC1412: 
WebModule[] ServletContext.log():/!\ FAILSAFE /!\  Thu Dec 11 16:14:13 
-0500 2008
Status: 500 Internal Server Error
undefined method `[]' for nil:NilClass
/Applications/NetBeans/glassfish-v2ur2/domains/domain1/applications/j2ee-modules/WebSite/WEB-INF/gems/gems/actionpack-2.2.2/lib/action_controller/request.rb:597:in `clean_up_ajax_request_body!'
/Applications/NetBeans/glassfish-v2ur2/domains/domain1/applications/j2ee-modules/WebSite/WEB-INF/gems/gems/actionpack-2.2.2/lib/action_controller/request.rb:508:in `parse_formatted_request_parameters'
/Applications/NetBeans/glassfish-v2ur2/domains/domain1/applications/j2ee-modules/WebSite/WEB-INF/gems/gems/actionpack-2.2.2/lib/action_controller/request.rb:441:in `request_parameters'
/Applications/NetBeans/glassfish-v2ur2/domains/domain1/applications/j2ee-modules/WebSite/WEB-INF/gems/gems/actionpack-2.2.2/lib/action_controller/request.rb:392:in `parameters'
/Applications/NetBeans/glassfish-v2ur2/domains/domain1/applications/j2ee-modules/WebSite/WEB-INF/gems/gems/actionpack-2.2.2/lib/action_controller/request.rb:30:in `request_method'
/Applications/NetBeans/glassfish-v2ur2/domains/domain1/applications/j2ee-modules/WebSite/WEB-INF/gems/gems/activesupport-2.2.2/lib/active_support/memoizable.rb:86:in `request_method'
/Applications/NetBeans/glassfish-v2ur2/domains/domain1/applications/j2ee-modules/WebSite/WEB-INF/gems/gems/actionpack-2.2.2/lib/action_controller/request.rb:40:in `method'
/Applications/NetBeans/glassfish-v2ur2/domains/domain1/applications/j2ee-modules/WebSite/WEB-INF/gems/gems/actionpack-2.2.2/lib/action_controller/routing/route_set.rb:433:in `extract_request_environment'
/Applications/NetBeans/glassfish-v2ur2/domains/domain1/applications/j2ee-modules/WebSite/WEB-INF/gems/gems/actionpack-2.2.2/lib/action_controller/routing/route_set.rb:386:in `recognize'
/Applications/NetBeans/glassfish-v2ur2/domains/domain1/applications/j2ee-modules/WebSite/WEB-INF/gems/gems/actionpack-2.2.2/lib/action_controller/dispatcher.rb:182:in `handle_request'
/Applications/NetBeans/glassfish-v2ur2/domains/domain1/applications/j2ee-modules/WebSite/WEB-INF/gems/gems/actionpack-2.2.2/lib/action_controller/dispatcher.rb:110:in `dispatch_unlocked'
/Applications/NetBeans/glassfish-v2ur2/domains/domain1/applications/j2ee-modules/WebSite/WEB-INF/gems/gems/actionpack-2.2.2/lib/action_controller/dispatcher.rb:120:in `dispatch'
/Applications/NetBeans/glassfish-v2ur2/domains/domain1/applications/j2ee-modules/WebSite/WEB-INF/gems/gems/actionpack-2.2.2/lib/action_controller/dispatcher.rb:132:in `dispatch_cgi'
/Applications/NetBeans/glassfish-v2ur2/domains/domain1/applications/j2ee-modules/WebSite/WEB-INF/gems/gems/actionpack-2.2.2/lib/action_controller/dispatcher.rb:39:in `dispatch'
/Applications/NetBeans/glassfish-v2ur2/domains/domain1/generated/jsp/j2ee-modules/WebSite/loader/rack/adapter/rails.rb:37:in `serve_rails'
/Applications/NetBeans/glassfish-v2ur2/domains/domain1/generated/jsp/j2ee-modules/WebSite/loader/rack/adapter/rails.rb:44:in `call'
/Applications/NetBeans/glassfish-v2ur2/domains/domain1/generated/jsp/j2ee-modules/WebSite/loader/jruby/rack/rails.rb:145:in `call'
/Applications/NetBeans/glassfish-v2ur2/domains/domain1/generated/jsp/j2ee-modules/WebSite/loader/rack/handler/servlet.rb:17:in `call':1
|#]

I'll keep an eye out for this error too.
Jay
-still without power at home :(



Dec 15, 2008 05:57:27 PM, removed_email_address@domain.invalid wrote:
I remember seeing it mentioned some time ago, but not recently...seems
like another case for updating to more recent JRuby, I suppose :(

AD wrote:
> i think i asked this once before, but just curious if anyone has seen
> this recently. Strangely this happened on all 4 of my app servers at
> the same time, so just curious if anyone has seen this of late. Jruby
> 1.1.4, Tomcat 5.5.27, Java 1.6, Redhat Enterprise Linux 5
>
> IOError (IO Error):
>
> /gems/gems/actionpack-2.1.1/lib/action_controller/request.rb:420:in `parse_formatted_request_parameters'
>
> /gems/gems/actionpack-2.1.1/lib/action_controller/cgi_process.rb:80:in `request_parameters'
>
> /gems/gems/actionpack-2.1.1/lib/action_controller/request.rb:307:in `parameters'
>
> /gems/gems/actionpack-2.1.1/lib/action_controller/request.rb:22:in `request_method'
>
> /gems/gems/actionpack-2.1.1/lib/action_controller/request.rb:35:in `method'
>
> /gems/gems/actionpack-2.1.1/lib/action_controller/routing/route_set.rb:431:in `extract_request_environment'
>
> /gems/gems/actionpack-2.1.1/lib/action_controller/routing/route_set.rb:384:in `recognize'
>
> Adam


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email



To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email