Re: Re: find_usrps only succeed when an sniffer is ON

Thanks for your quick answer. A problem with a firewall was an idea
that also came to my mind but I disabled the Ubuntu firewall with the
command “sudo ufw disable” so that no firewall is running into my
machine and the USRP2-Host computer connection is made directly with a
1 Gb ethernet wire.

Furthermore there were no errors during the installation of the
software (via package manager).I run out of ideas…any suggestion?

Jorge.

On 09/07/2010 04:43 AM, Jorge M. wrote:

00:50:c2:85:35:a2 hw_rev = 0x0400

When a sniffer is running, the ethernet interface is placed into
“promiscuous” mode in which all ethernet frames are processed and passed
up to higher layers in the networking stack. In non-promiscuous
mode, only frames that are addressed to the particular hosts ethernet
address, and the broadcast address, are forwarded up the stack.

My understanding is that find_usrps sends out a broadcast packet, and
the responding USRP2 replies using a broadcast packet, but even
in non-promiscuous mode, the hosts interface should pass the broadcast
traffic “upwards”. I wonder if there’s some interaction with
firewall rules at play here as well?

Marcus L.
Principal Investigator
Shirleys Bay Radio Astronomy Consortium
http://www.sbrac.org

On 09/07/2010 03:12 PM, Jorge M. wrote:

Jorge,

What are the permissions on:

/usr/local/bin/usrp2_socket_opener

They need to be 4755 in order for non-privileged apps to work correctly
with the raw ethernet interface.


Marcus L.
Principal Investigator
Shirleys Bay Radio Astronomy Consortium
http://www.sbrac.org

Furthermore there were no errors during the installation of the
software (via package manager).I run out of ideas…any suggestion?

Are you certain that Network Manager is not interfering with the state
of your ethernet interface? The default config likes to enable and
disable the interface each time the link goes away (ie, power up and
power down of the USRP2) … perhaps the sniffer is having some
influence on this behavior from Network Manager

Also, be certain you are using no switches, hubs or anything else
between the host PC and USRP2.

Jason

Marcus,

I set permissions as you said:
/usr/bin$ sudo chmod 4775 usrp2_socket_opener
However it does not fix the problem. Only when setting my Ethernet
interface to promiscuous mode with:
sudo ifconfig eth0 promisc up
‘find_usrps’ does work perfectly.
If I execute
sudo ifconfig eth0 -promisc
Again there is no connection with the USRP2

Is there any other file which needs permissions ?
Jorge.

What are the permissions on:

/usr/local/bin/usrp2_socket_opener

They need to be 4755 in order for non-privileged apps to work correctly
with the raw ethernet interface.


Marcus L.
Principal Investigator
Shirleys Bay Radio Astronomy Consortium
http://www.sbrac.org

You may have done this already, but check that the network port is eth0,
which
find_usrp’s uses by default.

I had similar problem after inserting another network card, check
/etc/udev/rules.d/70-persistent-net.rules…

D.

----- Original Message ----
From: Marcus D. Leech [email protected]
To: [email protected]
Sent: Tue, 7 September, 2010 20:35:58
Subject: Re: [Discuss-gnuradio] find_usrps only succeed when an sniffer
is ON

On 09/07/2010 03:12 PM, Jorge M. wrote:

Jorge,

What are the permissions on:

/usr/local/bin/usrp2_socket_opener

They need to be 4755 in order for non-privileged apps to work correctly
with the raw ethernet interface.


Marcus L.
Principal Investigator
Shirleys Bay Radio Astronomy Consortium
http://www.sbrac.org


Discuss-gnuradio mailing list
[email protected]
http://lists.gnu.org/mailman/listinfo/discuss-gnuradio

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs