Re: Re: a problem with warbler or maybe it's my problem or is it something in the jruby distn?


#1

hey,

I've just upgraded to jruby 1.1.5 and am using warbler 0.9.11 (and upgraded to rails 2.2)
I am trying to war up my application and am getting the following error:

Cannot load gem at [/Users/home/Projects/blah/Externals/jruby-1.1.5/lib/ruby/gems/1.8/cache/sources-0.0.1.gem]

When I goto the cache directory the sources-0.0.1.gem isn't there. 
I'm about to go and get it (or build it my self from the gemspec) but my question is... Should the gem be in the cache directory as part of the jruby distn? 
Or should I not be packaging it up with my War file due to the fact that Warbler already has jruby-complete-1.1.4.jar in it's lib directory ... and btw should I go and get the 1.1.5 version of jruby complete and replace that in the warbler 0.9.11?  or maybe I should go get the edge of warbler and it will have it?



Thanks!
Jay



To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#2

Jay McGaffigan wrote:

When I goto the cache directory the sources-0.0.1.gem isn’t there.
I’m about to go and get it (or build it my self from the gemspec) but my
question is… Should the gem be in the cache directory as part of the
jruby distn?
Or should I not be packaging it up with my War file due to the fact that
Warbler already has jruby-complete-1.1.4.jar in it’s lib directory …
and btw should I go and get the 1.1.5 version of jruby complete and
replace that in the warbler 0.9.11? or maybe I should go get the edge
of warbler and it will have it?

Hmm, are you sure you aren’t picking up an older version of RubyGems or
JRuby or possible running MRI? I believe that should be shipped with
JRuby.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email