Re: problem in first usage of nginx

Hello Alexander,
I solved the first problem.
But I still can not use chunkin module.
I followed the exact step in your link.

Following is the .configure result:

[email protected]:~/nginx-0.8.41$ ./configure
–add-module=./agentzh-chunkin-nginx-module-b0a3ee3
checking for OS

  • Linux 2.6.24-27-server x86_64
    checking for C compiler … found
  • using GNU C compiler
  • gcc version: 4.2.4 (Ubuntu 4.2.4-1ubuntu4)
    checking for gcc -pipe switch … found
    checking for gcc builtin atomic operations … found
    checking for gcc variadic macros … found
    checking for C99 variadic macros … found
    checking for unistd.h … found
    checking for inttypes.h … found
    checking for limits.h … found
    checking for sys/filio.h … not found
    checking for sys/param.h … found
    checking for sys/mount.h … found
    checking for sys/statvfs.h … found
    checking for crypt.h … found
    checking for Linux specific features
    checking for epoll … found
    checking for sendfile() … found
    checking for sendfile64() … found
    checking for sys/prctl.h … found
    checking for prctl(PR_SET_DUMPABLE) … found
    checking for sched_setaffinity() … found
    checking for crypt_r() … found
    checking for sys/vfs.h … found
    checking for nobody group … not found
    checking for nogroup group … found
    checking for poll() … found
    checking for /dev/poll … not found
    checking for kqueue … not found
    checking for crypt() … not found
    checking for crypt() in libcrypt … found
    checking for F_READAHEAD … not found
    checking for posix_fadvise() … found
    checking for O_DIRECT … found
    checking for F_NOCACHE … not found
    checking for directio() … not found
    checking for statfs() … found
    checking for statvfs() … found
    checking for dlopen() … not found
    checking for dlopen() in libdl … found
    checking for sched_yield() … found
    configuring additional modules
    adding module in ./agentzh-chunkin-nginx-module-b0a3ee3
  • ngx_http_chunkin_filter_module was configured
    checking for PCRE library … found
    checking for system md library … not found
    checking for system md5 library … not found
    checking for OpenSSL md5 crypto library … found
    checking for zlib library … found
    creating objs/Makefile
    checking for int size … 4 bytes
    checking for long size … 8 bytes
    checking for long long size … 8 bytes
    checking for void * size … 8 bytes
    checking for uint64_t … found
    checking for sig_atomic_t … found
    checking for sig_atomic_t size … 4 bytes
    checking for socklen_t … found
    checking for in_addr_t … found
    checking for in_port_t … found
    checking for rlim_t … found
    checking for uintptr_t … uintptr_t found
    checking for system endianess … little endianess
    checking for size_t size … 8 bytes
    checking for off_t size … 8 bytes
    checking for time_t size … 8 bytes
    checking for setproctitle() … not found
    checking for pread() … found
    checking for pwrite() … found
    checking for strerror_r() … found but is not working
    checking for gnu style strerror_r() … found
    checking for sys_errlist[] … found
    checking for localtime_r() … found
    checking for posix_memalign() … found
    checking for memalign() … found
    checking for mmap(MAP_ANON|MAP_SHARED) … found
    checking for mmap("/dev/zero", MAP_SHARED) … found
    checking for System V shared memory … found
    checking for struct msghdr.msg_control … found
    checking for ioctl(FIONBIO) … found
    checking for struct tm.tm_gmtoff … found
    checking for struct dirent.d_namlen … not found
    checking for struct dirent.d_type … found

Configuration summary

  • using system PCRE library
  • OpenSSL library is not used
  • md5: using system crypto library
  • sha1 library is not used
  • using system zlib library

nginx path prefix: “/usr/local/nginx”
nginx binary file: “/usr/local/nginx/sbin/nginx”
nginx configuration prefix: “/usr/local/nginx/conf”
nginx configuration file: “/usr/local/nginx/conf/nginx.conf”
nginx pid file: “/usr/local/nginx/logs/nginx.pid”
nginx error log file: “/usr/local/nginx/logs/error.log”
nginx http access log file: “/usr/local/nginx/logs/access.log”
nginx http client request body temporary files: “client_body_temp”
nginx http proxy temporary files: “proxy_temp”
nginx http fastcgi temporary files: “fastcgi_temp”
nginx http uwsgi temporary files: “uwsgi_temp”

Thank you so much.
Yanxin

for ubuntu - best way use deb package. Build deb package with add
chunkin module.

or simple way (but worst ):

make
make install

see:
http://www.debian.org/doc/FAQ/ch-pkg_basics.en.html
(http://www.debian.org/doc/FAQ/ch-pkg_basics.en.html)

Thu, 24 Mar 2011 13:37:29 -0700 Yanxin Z. [email protected]:

Hello Alexander,I solved the first problem. But I still can not use
chunkin module. I followed the exact step in your link.
Following is the .configure result:
[email protected]:~/nginx-0.8.41$ ./configure
–add-module=./agentzh-chunkin-nginx-module-b0a3ee3checking for OS +
Linux 2.6.24-27-server x86_64checking for C compiler … found + using
GNU C compiler + gcc version: 4.2.4 (Ubuntu 4.2.4-1ubuntu4)checking for
gcc -pipe switch … foundchecking for gcc builtin atomic operations …
foundchecking for gcc variadic macros … foundchecking for C99 variadic
macros … foundchecking for unistd.h … foundchecking for inttypes.h
… foundchecking for limits.h … foundchecking for sys/filio.h … not
foundchecking for sys/param.h … foundchecking for sys/mount.h …
foundchecking for sys/statvfs.h … foundchecking for crypt.h …
foundchecking for Linux specific featureschecking for epoll …
foundchecking for sendfile() … foundchecking for sendfile64() …
foundchecking for sys/prctl.h … foundchecking for
prctl(PR_SET_DUMPABLE) … foundchecking for sched_setaffinity() …
foundchecking for crypt_r() … foundchecking for sys/vfs.h …
foundchecking for nobody group … not foundchecking for nogroup group
… foundchecking for poll() … foundchecking for /dev/poll … not
foundchecking for kqueue … not foundchecking for crypt() … not
foundchecking for crypt() in libcrypt … foundchecking for F_READAHEAD
… not foundchecking for posix_fadvise() … foundchecking for O_DIRECT
… foundchecking for F_NOCACHE … not foundchecking for directio() …
not foundchecking for statfs() … foundchecking for statvfs() …
foundchecking for dlopen() … not foundchecking for dlopen() in libdl
… foundchecking for sched_yield() … foundconfiguring additional
modulesadding module in ./agentzh-chunkin-nginx-module-b0a3ee3 +
ngx_http_chunkin_filter_module was configuredchecking for PCRE library
… foundchecking for system md library … not foundchecking for system
md5 library … not foundchecking for OpenSSL md5 crypto library …
foundchecking for zlib library … foundcreating objs/Makefilechecking
for int size … 4 byteschecking for long size … 8 byteschecking for
long long size … 8 byteschecking for void * size … 8 byteschecking
for uint64_t … foundchecking for sig_atomic_t … foundchecking for
sig_atomic_t size … 4 byteschecking for socklen_t … foundchecking
for in_addr_t … foundchecking for in_port_t … foundchecking for
rlim_t … foundchecking for uintptr_t … uintptr_t foundchecking for
system endianess … little endianesschecking for size_t size … 8
byteschecking for off_t size … 8 byteschecking for time_t size … 8
byteschecking for setproctitle() … not foundchecking for pread() …
foundchecking for pwrite() … foundchecking for strerror_r() … found
but is not workingchecking for gnu style strerror_r() … foundchecking
for sys_errlist[] … foundchecking for localtime_r() … foundchecking
for posix_memalign() … foundchecking for memalign() … foundchecking
for mmap(MAP_ANON|MAP_SHARED) … foundchecking for mmap("/dev/zero",
MAP_SHARED) … foundchecking for System V shared memory …
foundchecking for struct msghdr.msg_control … foundchecking for
ioctl(FIONBIO) … foundchecking for struct tm.tm_gmtoff …
foundchecking for struct dirent.d_namlen … not foundchecking for
struct dirent.d_type … found
Configuration summary + using system PCRE library + OpenSSL library is
not used + md5: using system crypto library + sha1 library is not used

  • using system zlib library
    nginx path prefix: “/usr/local/nginx” nginx binary file:
    “/usr/local/nginx/sbin/nginx” nginx configuration prefix:
    “/usr/local/nginx/conf” nginx configuration file:
    “/usr/local/nginx/conf/nginx.conf” nginx pid file:
    “/usr/local/nginx/logs/nginx.pid” nginx error log file:
    “/usr/local/nginx/logs/error.log” nginx http access log file:
    “/usr/local/nginx/logs/access.log” nginx http client request body
    temporary files: “client_body_temp” nginx http proxy temporary files:
    “proxy_temp” nginx http fastcgi temporary files: “fastcgi_temp” nginx
    http uwsgi temporary files: “uwsgi_temp”

Thank you so much. Yanxin

On Thu, Mar 24, 2011 at 1:25 PM, [email protected] wrote:
Send nginx mailing list submissions to
[email protected]

To subscribe or unsubscribe via the World Wide Web, visit
http://nginx.org/mailman/listinfo/nginx
(http://nginx.org/mailman/listinfo/nginx)
or, via email, send a message with subject or body ‘help’ to
[email protected]

You can reach the person managing the list at
[email protected]

When replying, please edit your Subject line so it is more specific
than “Re: Contents of nginx digest…”

Today’s Topics:

  1. Re: What’s fastcgi_param scope (Maxim D.)
  2. Re: .htaccess to nginx, how to make wp-minify work? (kaspars)
  3. Re: What’s fastcgi_param scope (Jakub Zalas)
  4. Re: upload module help (vetri)
  5. Re: HTTPS - NGINX with Passenger webservers behind F5 load
    balancer (Jarek Zmudzinski)
  6. Re: HTTPS - NGINX with Passenger webservers behind F5 load
    balancer (Vitaly T.)
  7. problem in first usage of nginx (Yanxin Z.)
  8. Re: problem in first usage of nginx (Ivan)
  9. Re: problem in first usage of nginx (Alexander K.)

Message: 1
Date: Thu, 24 Mar 2011 12:24:16 +0300
From: Maxim D. [email protected]
To: [email protected]
Subject: Re: What’s fastcgi_param scope
Message-ID: [email protected]
Content-Type: text/plain; charset=us-ascii

Hello!

On Wed, Mar 23, 2011 at 04:34:38PM -0700, Jakub Zalas wrote:

Hi,

I’m experiencing odd behavior of fastcgi_param.

Based on the URL I’d like to pass additional parameters to PHP.

For example:

location ~ “^/foo/bar$” {

Just a side note: use “location = /foo/bar” instead.

this is not passed to fastcgi and not acesible via $_SERVER

fastcgi_param _ROUTING__route foo;
fastcgi_index app.php;

Just a side note: fastcgi_index doesn’t make sense here at all.

rewrite ^(.*) /app.php last;
}

As soon as you did internal redirect (with rewrite) -
configuration in this location no longer applies. Instead
configuration in destination location will be used.

fastcgi_param  SCRIPT_FILENAME  /var/www/$host/web$script;
fastcgi_param  PATH_INFO        $path_info;
fastcgi_param  SCRIPT_NAME $script;

}

… and this one has no “fastcgi_param _ROUTING__route” set.

I also tried nesting location but the result is the same.
fastcgi_param defined in nested location block is not passed to PHP.

Could anyone explain me why it works this way?

See above. Solution is to write explicitly what you want to
happen instead of using internal redirects, i.e. something like
this:

location = /foo/bar {
    fastcgi_pass 127.0.0.1:9000;
    include /etc/nginx/fastcgi_params;
    fastcgi_param SCRIPT_FILENAME /var/www/$host/web/app.php;
    fastcgi_param _ROUTING__route foo;
    ...
}

Maxim D.

p.s. The only thing which survives internal redirect is variables.
Theoretically you may rewrite your config to set some variables
before rewrite and then use appropriate fastcgi_param in .php
location. But it’s not going to scale well and not recommended.


Message: 2
Date: Thu, 24 Mar 2011 05:31:35 -0400
From: “kaspars” [email protected]
To: [email protected]
Subject: Re: .htaccess to nginx, how to make wp-minify work?
Message-ID:
[email protected]

Content-Type: text/plain; charset=UTF-8

If your WordPress installation works, WP Minify does too! There is no
need for special rewrites.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,185233,185351#msg-185351
(http://forum.nginx.org/read.php?2,185233,185351#msg-185351)


Message: 3
Date: Thu, 24 Mar 2011 03:22:56 -0700 (PDT)
From: Jakub Zalas [email protected]
To: [email protected]
Subject: Re: What’s fastcgi_param scope
Message-ID:
[email protected]
Content-Type: text/plain; charset=ISO-8859-1

On Mar 24, 10:24?am, Maxim D. [email protected] wrote:

Hello!

On Wed, Mar 23, 2011 at 04:34:38PM -0700, Jakub Zalas wrote:

Hi,

Just a side note: use “location = /foo/bar” instead.

Actually I need a regexp here. I just simplified my example.

As soon as you did internal redirect (with rewrite) -
configuration in this location no longer applies. ?Instead
configuration in destination location will be used.

This explains a lot. Thanks!

? ? }

Maxim D.

p.s. The only thing which survives internal redirect is variables. ?
Theoretically you may rewrite your config to set some variables
before rewrite and then use appropriate fastcgi_param in .php
location. ?But it’s not going to scale well and not recommended.

Thank you. Your suggestions helped me a lot.


Message: 4
Date: Thu, 24 Mar 2011 08:10:03 -0400
From: “vetri” [email protected]
To: [email protected]
Subject: Re: upload module help
Message-ID:
[email protected]

Content-Type: text/plain; charset=UTF-8

mr alexander,

i am already using form to to upload files. my doubt is why its not
saving the file in uploaded file name.it is saving the file in number
form like this 0040353221 .i dont know why its happening and one more
question how to parse header using nginx configuration ?

thanks for the reply

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,185057,185375#msg-185375
(http://forum.nginx.org/read.php?2,185057,185375#msg-185375)


Message: 5
Date: Thu, 24 Mar 2011 13:25:10 +0100
From: Jarek Zmudzinski [email protected]
To: [email protected]
Subject: Re: HTTPS - NGINX with Passenger webservers behind F5 load
balancer
Message-ID: [email protected]
Content-Type: text/plain; charset=UTF-8

Jarek Zmudzinski wrote in post #986664:

What I would like is to NGINX listen to https:// on port 80 this way any
https request to F5 LB could still be taken care of by NGINX listening
on port 80 without being redirected to http. But I am afraid it’s not
possible.

Problem solved. It was a F5 configuration issue. NGINX doesn’t redirect
https:// on port 80 to http://. (http://.)

Thanks.


Posted via http://www.ruby-forum.com/ (http://www.ruby-forum.com/) .


Message: 6
Date: Thu, 24 Mar 2011 20:40:17 +0300
From: Vitaly T. remov[email protected]
To: [email protected]
Subject: Re: HTTPS - NGINX with Passenger webservers behind F5 load
balancer
Message-ID: [email protected]
Content-Type: text/plain; charset=UTF-8; format=flowed

Thanks for your follow up.


Regards, Vitaly T.
System A.
U.S. +1 (206) 905-9939
Russia +7 911 094-2035


Message: 7
Date: Thu, 24 Mar 2011 13:03:36 -0700
From: Yanxin Z. [email protected]
To: [email protected]
Subject: problem in first usage of nginx
Message-ID:
[email protected]
Content-Type: text/plain; charset=“iso-8859-1”

Hello,
I have several questions about using NginX.

After I first install nginx-0.8.41 in Ubuntu 8.04 system, with the
default
.conf file.
I start nginx with 127.0.0.1:8000, however, I can not see the default
webpage. The browser can not connect to server.
Could anyone help me to figure it out?

I am following the instructions in
http://wiki.nginx.org/HttpChunkinModule
(http://wiki.nginx.org/HttpChunkinModule)

to configure nginx.
when I start nginx, I encounter the error:
[emerg]: unknown directive “chunkin” in ./conf/nginx.conf:36

The line is
35 server {
36 chunkin on;
37 listen 127.0.0.1:8000;

Thanks,
Yanxin
-------------- next part --------------
An HTML attachment was scrubbed…
URL: <
http://nginx.org/pipermail/nginx/attachments/20110324/cff6ff28/attachment-0001.html
(http://nginx.org/pipermail/nginx/attachments/20110324/cff6ff28/attachment-0001.html)


Message: 8
Date: Thu, 24 Mar 2011 23:23:29 +0300
From: Ivan [email protected]
To: [email protected]
Subject: Re: problem in first usage of nginx
Message-ID: [email protected]
Content-Type: text/plain; charset=“koi8-r”

( http://wiki.nginx.org/HttpChunkinModule
(http://wiki.nginx.org/HttpChunkinModule) )
http://wiki.nginx.org/HttpChunkinModule
(http://wiki.nginx.org/HttpChunkinModule) (
http://wiki.nginx.org/HttpChunkinModule
(http://wiki.nginx.org/HttpChunkinModule) )
This module is not distributed with the Nginx source. See the
installation instructions (
http://wiki.nginx.org/HttpChunkinModule#Installation
(http://wiki.nginx.org/HttpChunkinModule#Installation) ) .

Thu, 24 Mar 2011 13:03:36 -0700 ??? ?? Yanxin Z.
[email protected]:

Hello, I have several questions about using NginX.

  1. After I first install nginx-0.8.41 in Ubuntu 8.04 system, with the
    default .conf file. I start nginx with 127.0.0.1:8000, however, I can
    not see the default webpage. The browser can not connect to server.
    Could anyone help me to figure it out?

I am following the instructions in (
http://wiki.nginx.org/HttpChunkinModule
(http://wiki.nginx.org/HttpChunkinModule) )
http://wiki.nginx.org/HttpChunkinModule
(http://wiki.nginx.org/HttpChunkinModule) (
http://wiki.nginx.org/HttpChunkinModule
(http://wiki.nginx.org/HttpChunkinModule) )
to configure nginx. when I start nginx, I encounter the error: [emerg]:
unknown directive “chunkin” in ./conf/nginx.conf:36
The line is 35 server { 36 chunkin on; 37 listen
127.0.0.1:8000;

Thanks,Yanxin


nginx mailing list
[email protected] (sentmsg?compose&amp;[email protected])
( http://nginx.org/mailman/listinfo/nginx
(http://nginx.org/mailman/listinfo/nginx) ) (
http://nginx.org/mailman/listinfo/nginx
(http://nginx.org/mailman/listinfo/nginx) )
http://nginx.org/mailman/listinfo/nginx
(http://nginx.org/mailman/listinfo/nginx) (
http://nginx.org/mailman/listinfo/nginx
(http://nginx.org/mailman/listinfo/nginx) )

-------------- next part --------------
An HTML attachment was scrubbed…
URL: <
http://nginx.org/pipermail/nginx/attachments/20110324/c7866067/attachment-0001.html
(http://nginx.org/pipermail/nginx/attachments/20110324/c7866067/attachment-0001.html)


Message: 9
Date: Thu, 24 Mar 2011 21:25:56 +0100
From: Alexander K. [email protected]
To: [email protected]
Subject: Re: problem in first usage of nginx
Message-ID: [email protected]
Content-Type: text/plain; charset=“iso-8859-1”; Format=“flowed”

Hello Yanxin,

starts nginx if you not set the chunkin on; option?

Chunkin is no build in option, you must build ngnix from source. Use

–add-module=/path/to/chunkin-nginx-module

while you configure…Described here:

http://wiki.nginx.org/HttpChunkinModule#Installation
(http://wiki.nginx.org/HttpChunkinModule#Installation)

If you already do this, please show us the output from

nginx -V

Cheers,
Alexander

On 24.03.2011 21:03, Yanxin Z. wrote:

37 listen 127.0.0.1:8000 < http://127.0.0.1:8000
(http://127.0.0.1:8000) >;
[email protected]
http://nginx.org/mailman/listinfo/nginx
(http://nginx.org/mailman/listinfo/nginx)

-------------- next part --------------
An HTML attachment was scrubbed…
URL: <
http://nginx.org/pipermail/nginx/attachments/20110324/e39e9822/attachment.html
(http://nginx.org/pipermail/nginx/attachments/20110324/e39e9822/attachment.html)



nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx
(http://nginx.org/mailman/listinfo/nginx)

End of nginx Digest, Vol 17, Issue 55


This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs