RE: NGINX proxy, 502 error while SSL handshaking to upstream

Hello!

On Tue, Feb 25, 2014 at 04:34:34PM +0100, Juan Matas wrote:

You have to use proxy_ssl_protocols, not ssl_protocols. See
http://nginx.org/r/proxy_ssl_protocols.

The proxy_ssl_ciphers directive may help, too, depending on what
exactly triggers the problem on your backend.


Maxim D.http://nginx.org/

Thanks Maxim D. for the answer
I tried that but did not work.

I tried using directives on nginx config file but the issue continue. I
can’t ensure but looks like Nginx was using TLSv1.1 or 1.2 anyway and
the
SSL handshake failed. And I didn’t find a way to disable this version of
the protocol.

So I fixed the problem compiling nginx(1.0.15) from source using openSSL
0.9.8e. This version of OpenSSL doesnt support TLSv1.1. And that’s
works. I
have no option, the provider that I’m dealing with doesn’t support
TLSv1.1
and they are not going to update his service.

Thanks,
Matas.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs