Re: nginx imap proxy - timeouts

Hi Dominic,

net.ipv4.ip_local_port_range = 32768 61000
stack (see notes in [1]) and 2000 concurrent LDAP Perl request you’ll
Regards
Dominic

[1] Linux Network Tuning for 2013 – Nate Wiger vs Software
[2] http://dak1n1.com/blog/12-nginx-performance-tuning
[3]

[4] http://blog.whatsapp.com/196/1-million-is-so-2011

Thank you for your help. These options we have already tried. We had the
same problem using a socket and increasing the option
net.ipv4.ip_local_port_range didn’t help. In the setup we’re already
using loadbalancer to balance the traffic on different hosts. Do you
have maybe any other suggestions?


Freundliche Grüße,

Falko König
Platform Engineer


domainfactory GmbH
Oskar-Messter-Str. 33
85737 Ismaning
Germany

Telefon: +49 (0)89 / 55266-371
Telefax: +49 (0)89 / 55266-222

E-Mail: [email protected]
Internet: www.df.eu

Registergericht: Amtsgericht München
HRB 150294, Geschäftsführer:
Peter Mueller, Tobias Mohr

Hi Falko

On 23/10/14 12:26, Falko Koenig wrote:

Thank you for your help. These options we have already tried. We had the
same problem using a socket and increasing the option
net.ipv4.ip_local_port_range didn’t help. In the setup we’re already
using loadbalancer to balance the traffic on different hosts. Do you
have maybe any other suggestions?

Without further informations the guessing goes on.

What version of nginx are you using?
Can you provide your configurations? Especially the timeout settings of
auth_http_timeout?

Some suggestions, if you haven’t tried them yet.
Are you measuring the response time of the HTTP auth request?

  • Add timing informations to you Perl script.
    Check the connection limits of your LDAP backends.

Regards
Dominic