RE: JRuby 1.7.4 warning - You have loaded arm-Linux/libjffi-1.2.so


#1

> From: Wayne M. <removed_email_address@domain.invalid> (Add as Preferred Sender)  
> Date: Sat, May 18, 2013 11:29 pm
> That's a different error, but you can work around it by executing
> jruby.sh with bash
> e.g.
> bash /opt/ruby/jruby/bin/jruby.sh -S gem

bash /opt/ruby/jruby/bin/jruby.sh -S gem list
works.

gem list
warning.

Output below
=====================================
craig@craigs:~$ uname -a
Linux craigs 3.8.0-21-generic #32-Ubuntu SMP Tue May 14 22:16:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

=====================================
craig@craigs:~$ jruby -v
jruby 1.7.4 (1.9.3p392) 2013-05-16 2390d3b on Java HotSpot(TM) 64-Bit Server VM 1.7.0_21-b11 [linux-amd64]
craig@craigs:~$ gem list

*** LOCAL GEMS ***

rake (10.0.3)

=====================================
craig@craigs:/opt/ruby/jruby/bin$ jruby -v
jruby 1.7.4 (1.9.3p392) 2013-05-16 2390d3b on Java HotSpot(TM) 64-Bit Server VM 1.8.0-ea-b90 +indy [linux-amd64]
craig@craigs:/opt/ruby/jruby/bin$ bash /opt/ruby/jruby/bin/jruby.sh -S gem list

*** LOCAL GEMS ***

rake (10.0.3)

=====================================
craig@craigs:~$ which gem
/opt/ruby/jruby/bin/gem
craig@craigs:~$ gem list
Java HotSpot(TM) 64-Bit Server VM warning: You have loaded library /opt/ruby/jruby-1.7.4/lib/native/arm-Linux/libjffi-1.2.so which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.

*** LOCAL GEMS ***

rake (10.0.3)


#2

Added comment to
https://github.com/jruby/jruby/issues/626

gist
https://gist.github.com/CootCraig/5618061


#3

Hiro released a new jruby-launcher; perhaps you can try that out and see
if
it fixes your issues?

  • Charlie