Re: irb and readline

[email protected] wrote:

Got it. So, is there anyway to shut off history from the windows
console? That would probably solve the large-line-bug while still
allowing tab completion.

I was able to lower buffer size and number of buffers to 1, but it
didn’t solve the problem. (The console did keep a 1 line history,
though, so this still might be the problem.)

I tried

C:>DOSKEY /listsize=0

That seems to remove the history in cmd.exe?

HTH
torben

Hi,

I have tried irb after this command:

C:>DOSKEY /listsize=0

That bug is still there. But when I use the old command.com it’s all
good. Thanks Dave for this tip !


Martins

Torben Wölm wrote:

I tried

C:>DOSKEY /listsize=0

That seems to remove the history in cmd.exe?

Yes, it does - thanks.

Unfortunately, irb’s readline still doesn’t work, so my theory was
wrong. Oh well.

fr listserv:

Yes, it does - thanks.

Unfortunately, irb’s readline still doesn’t work, so my theory was

wrong. Oh well.

fwiw,
on my windows cmd.exe properties, i have:

Screen buffer size:
width: 80
height: 999

Window size:
width: 80
height: 41

uncheck: Let system position window

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs