Re: installation error


#1

hey everyone,

Hi Ziad,

Im using a ubuntu 6.10 ,ive tried compiling the gnuradio but when i
tried

gr_block.cc:112: error: ‘d_detail’ was not declared in this scope
/home/ziad/Desktop/gnuradio-3.0.3/gnuradio-core/src' make[1]: *** [install-recursive] Error 1 make[1]: Leaving directory/home/ziad/Desktop/gnuradio- 3.0.3
/gnuradio-core’
make: *** [install-recursive] Error 1

I believe dependencies for gnuradio are not configured properly and you
are
doing make. well, before doing make you need to be sure about the
dependencies of GNURadio. You can do that by following commands:

$ script config.check
$ ./configure --enable-maintainer-mode
$ exit

this way you will generate a file called script.config in the same
directory
of ./configure file. Open the file and then at the end you will find
what
blocks could be installed and what not. Remember following blocks are
must
for gnuradio to work:

  1. gr-core
  2. gr-usrp
  3. gr-wxgui
  4. gr-alsa
  5. usrp

If these blocks can be installed then I dont think you will be in
trouble,
well its better to install all the possible blocks. Say if blosk gr-xxx
is
under Not-Install category, you search for xxx in the file and then you
can
find the reason why is that block not being installed. Well, you will
find
the dependency there (say it yyy), and then try installing the packages
from
repository byt using following command:

$ yum install yyy

if this does not work then try

$ yum install yyy*

and even this does not work then try

$ yum install yyy
and if this also does not work then you need to find the source code of
yyy
and install from that. It may happen that you need other dependent
components for yyy while using source code, again you can use the script
saving technique and try to install that dependency using repository (or
source).

Can some1 help

I hope this may help you, even you are unable to do so, its better you
send
the file called config.check and then we can be in better situation to
help
you further.

thanks for your time

welcome

ziad

Tarun