Re: I need some help with OptionsParser


#1

c:\temp>

This thread is a testament to why I wrote the getopt package:

test.rb

require ‘getopt/long’
include Getopt

opts = Long.getopts([’–size’, ‘-s’, REQUIRED])
p opts[‘size’]

C:\ruby test.rb -s ‘Very Big’
“Very Big”

C:\

gem install getopt :slight_smile:

Regards,

Dan


#2

Works!

Thanks :slight_smile:


#3

PS: Thanks to everyone for the help! THought I was crazy here…